aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-07 08:48:15 +0800
committermiwi <miwi@FreeBSD.org>2007-10-07 08:48:15 +0800
commitca1ac66e36da3dd1cb8eda2f2987ed214b7df2c6 (patch)
treeb31bfdac1d0e148b2a6d5d8a3ff303e74f51983a /net-mgmt
parentc0f187fe9bf825115a54181321603c10cd83dcfe (diff)
downloadfreebsd-ports-gnome-ca1ac66e36da3dd1cb8eda2f2987ed214b7df2c6.tar.gz
freebsd-ports-gnome-ca1ac66e36da3dd1cb8eda2f2987ed214b7df2c6.tar.zst
freebsd-ports-gnome-ca1ac66e36da3dd1cb8eda2f2987ed214b7df2c6.zip
- Update to 1.5.5
PR: 116985 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nfdump/Makefile11
-rw-r--r--net-mgmt/nfdump/distinfo6
-rw-r--r--net-mgmt/nfdump/files/patch-Makefile.in6
-rw-r--r--net-mgmt/nfdump/files/patch-ft2nfdump.c12
4 files changed, 17 insertions, 18 deletions
diff --git a/net-mgmt/nfdump/Makefile b/net-mgmt/nfdump/Makefile
index 926e74554bec..f142f2f6c012 100644
--- a/net-mgmt/nfdump/Makefile
+++ b/net-mgmt/nfdump/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nfdump
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.5
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,8 +14,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Command-line tools to collect and process NetFlow data
+BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} --enable-nfprofile --with-rrdpath=${LOCALBASE}
#flow-tools support
OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
@@ -29,8 +32,8 @@ OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
CONFIGURE_ARGS= --enable-compat14
.endif
-PLIST_FILES= bin/nfcapd bin/nfdump bin/nfprofile bin/nfreplay bin/nfclean.pl
-MAN1= nfcapd.1 nfdump.1 nfprofile.1 nfreplay.1
+PLIST_FILES= bin/nfcapd bin/nfdump bin/nfprofile bin/nfreplay bin/nfexpire
+MAN1= nfcapd.1 nfdump.1 nfprofile.1 nfreplay.1 nfexpire.1
PORTDOCS= AUTHORS ChangeLog INSTALL README
#flow-tools support
diff --git a/net-mgmt/nfdump/distinfo b/net-mgmt/nfdump/distinfo
index a416dda6611e..03d4e02be1b4 100644
--- a/net-mgmt/nfdump/distinfo
+++ b/net-mgmt/nfdump/distinfo
@@ -1,3 +1,3 @@
-MD5 (nfdump-1.5.2.tar.gz) = 4447c3338cc7eae6eee5288889f27d28
-SHA256 (nfdump-1.5.2.tar.gz) = d86d5ce09a67913fba93ca19321d1c20edcbbd4139b2b87d79b663d983dd1ee5
-SIZE (nfdump-1.5.2.tar.gz) = 224287
+MD5 (nfdump-1.5.5.tar.gz) = b421b1b95ab649d886e1fafe51fc5fe8
+SHA256 (nfdump-1.5.5.tar.gz) = 564ed3490fa5062e1435f59e9fe8e5e1fcf38fd74a50001cd905444eae7b2551
+SIZE (nfdump-1.5.5.tar.gz) = 281546
diff --git a/net-mgmt/nfdump/files/patch-Makefile.in b/net-mgmt/nfdump/files/patch-Makefile.in
index ff2f4e15cc62..29a56d6b2279 100644
--- a/net-mgmt/nfdump/files/patch-Makefile.in
+++ b/net-mgmt/nfdump/files/patch-Makefile.in
@@ -3,7 +3,7 @@ $FreeBSD$
--- Makefile.in.orig
+++ Makefile.in
-@@ -100,11 +100,11 @@
+@@ -108,8 +108,8 @@
test -d $(MANDIR)/man1 || install -d -o root -g bin -m 755 $(MANDIR)/man1
for file in $(OBJECTS); do \
if [ -f $$file.1 ]; then \
@@ -13,8 +13,4 @@ $FreeBSD$
+ $(BSD_INSTALL_MAN) $$file.1 $(MANDIR)/man1 ; \
fi \
done;
-- test -f $(PREFIX)/bin/nfclean.pl || $(INSTALL) -o root -g bin -m 755 nfclean.pl $(PREFIX)/bin
-+ test -f $(PREFIX)/bin/nfclean.pl || $(BSD_INSTALL_SCRIPT) nfclean.pl $(PREFIX)/bin
- uninstall:
- for file in $(OBJECTS); do \
diff --git a/net-mgmt/nfdump/files/patch-ft2nfdump.c b/net-mgmt/nfdump/files/patch-ft2nfdump.c
index 2dbb1756cdf6..1910d7b254a4 100644
--- a/net-mgmt/nfdump/files/patch-ft2nfdump.c
+++ b/net-mgmt/nfdump/files/patch-ft2nfdump.c
@@ -3,12 +3,12 @@ $FreeBSD$
--- ft2nfdump.c.orig
+++ ft2nfdump.c
-@@ -64,7 +64,7 @@
- #endif
+@@ -66,7 +66,7 @@
+ #include "nffile.h"
+ #include "launch.h"
- #include "version.h"
-#include "ftbuild.h"
+/*#include "ftbuild.h"*/
- #include "nf_common.h"
- #include "nffile.h"
- #include "launch.h"
+
+ /* Global defines */
+ #define MAXRECORDS 30