aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2015-10-13 20:18:17 +0800
committerzi <zi@FreeBSD.org>2015-10-13 20:18:17 +0800
commitdd4e7b47e566077e2f5bba459e7a468718cbfef7 (patch)
tree0e7336c49c8a802655261bfa5faf5ce983325616 /net-mgmt
parentcfdf0ffe05022e41a8adf35fc23981ecc2b3cffd (diff)
downloadfreebsd-ports-gnome-dd4e7b47e566077e2f5bba459e7a468718cbfef7.tar.gz
freebsd-ports-gnome-dd4e7b47e566077e2f5bba459e7a468718cbfef7.tar.zst
freebsd-ports-gnome-dd4e7b47e566077e2f5bba459e7a468718cbfef7.zip
- Fix two memory leaks (reported in upstream bug #2674)
- Bump PORTREVISION Submitted by: Laurent GOUHIER <lg@efficientip.com> Obtained from: valgrind
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_tcp-mib_data__access_tcpConn__freebsd4.c11
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_udp-mib_data__access_udp__endpoint__freebsd4.c11
3 files changed, 24 insertions, 2 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 82cd8fda7886..d32da9791a8f 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
@@ -37,7 +37,7 @@ GNU_CONFIGURE= yes
USE_RC_SUBR= snmpd snmptrapd
USE_OPENSSL= yes
USE_LDCONFIG= yes
-USES= cpe perl5 libtool
+USES= cpe libtool perl5
CPE_VENDOR= net-snmp
USE_PERL5= build run
USE_CSTD= c99
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_tcp-mib_data__access_tcpConn__freebsd4.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_tcp-mib_data__access_tcpConn__freebsd4.c
new file mode 100644
index 000000000000..1716f18e78d2
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_tcp-mib_data__access_tcpConn__freebsd4.c
@@ -0,0 +1,11 @@
+--- agent/mibgroup/tcp-mib/data_access/tcpConn_freebsd4.c.orig 2015-10-13 12:04:38 UTC
++++ agent/mibgroup/tcp-mib/data_access/tcpConn_freebsd4.c
+@@ -216,6 +216,8 @@ _load(netsnmp_container *container, u_in
+ CONTAINER_INSERT(container, entry);
+ }
+
++ free(tcpcb_buf);
++
+ if(rc<0)
+ return rc;
+
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_udp-mib_data__access_udp__endpoint__freebsd4.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_udp-mib_data__access_udp__endpoint__freebsd4.c
new file mode 100644
index 000000000000..571c2a8e0534
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_udp-mib_data__access_udp__endpoint__freebsd4.c
@@ -0,0 +1,11 @@
+--- agent/mibgroup/udp-mib/data_access/udp_endpoint_freebsd4.c.orig 2015-10-13 12:04:44 UTC
++++ agent/mibgroup/udp-mib/data_access/udp_endpoint_freebsd4.c
+@@ -187,6 +187,8 @@ _load(netsnmp_container *container, u_in
+ CONTAINER_INSERT(container, entry);
+ }
+
++ free(udpcb_buf);
++
+ if(rc<0)
+ return rc;
+