aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-07-19 07:53:46 +0800
committerzi <zi@FreeBSD.org>2011-07-19 07:53:46 +0800
commite4181728f3f9b663d426700f3f1d684456c01ffb (patch)
treed1d7fd1a21df65488b902e416ca945b91fb60ffa /net-mgmt
parentf4510e5fe6b789e01151c2be7bb5efbd88bb4467 (diff)
downloadfreebsd-ports-gnome-e4181728f3f9b663d426700f3f1d684456c01ffb.tar.gz
freebsd-ports-gnome-e4181728f3f9b663d426700f3f1d684456c01ffb.tar.zst
freebsd-ports-gnome-e4181728f3f9b663d426700f3f1d684456c01ffb.zip
check_hp_bladechassis is a plugin for the Nagios monitoring software which
checks the hardware health of HP blade enclosures via SNMP. The plugin is only tested with the c7000 enclosure. WWW: http://folk.uio.no/trondham/software/check_hp_bladechassis.html PR: ports/158577 Submitted by: rpsfa@rit.edu (me) Approved by: tabthorpe (mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_hp_bladechassis/Makefile35
-rw-r--r--net-mgmt/nagios-check_hp_bladechassis/distinfo2
-rw-r--r--net-mgmt/nagios-check_hp_bladechassis/pkg-descr6
4 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 06fb24a480c7..97efd9c2daef 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -117,6 +117,7 @@
SUBDIR += nagios-check_cpu_usage
SUBDIR += nagios-check_email_delivery
SUBDIR += nagios-check_hdd_health
+ SUBDIR += nagios-check_hp_bladechassis
SUBDIR += nagios-check_ice
SUBDIR += nagios-check_kumofs
SUBDIR += nagios-check_memcached_paranoid
diff --git a/net-mgmt/nagios-check_hp_bladechassis/Makefile b/net-mgmt/nagios-check_hp_bladechassis/Makefile
new file mode 100644
index 000000000000..3978ca84ea7c
--- /dev/null
+++ b/net-mgmt/nagios-check_hp_bladechassis/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: nagios-check_email_delivery
+# Date created: 1 July 2011
+# Whom: Ryan Steinmetz
+#
+# $FreeBSD$
+
+PORTNAME= check_hp_bladechassis
+PORTVERSION= 1.0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://folk.uio.no/trondham/software/files/ \
+ http://people.rit.edu/rpsfa/distfiles/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Nagios Plugin to monitor your HP Blade Enclosure
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+MAN8= check_hp_bladechassis.8
+PLIST_FILES= libexec/nagios/check_hp_bladechassis
+PLIST_DIRSTRY= libexec/nagios/
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_hp_bladechassis ${PREFIX}/libexec/nagios/
+ ${INSTALL_MAN} ${WRKSRC}/check_hp_bladechassis.8 ${PREFIX}/man/man8/
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/nagios-check_hp_bladechassis/distinfo b/net-mgmt/nagios-check_hp_bladechassis/distinfo
new file mode 100644
index 000000000000..296bb5551f0d
--- /dev/null
+++ b/net-mgmt/nagios-check_hp_bladechassis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (check_hp_bladechassis-1.0.1.tar.gz) = 2a7c2b63fe8860d973fa4e0280fc9acb2e52fc0d04a4cbe36bf1b201934364a3
+SIZE (check_hp_bladechassis-1.0.1.tar.gz) = 27549
diff --git a/net-mgmt/nagios-check_hp_bladechassis/pkg-descr b/net-mgmt/nagios-check_hp_bladechassis/pkg-descr
new file mode 100644
index 000000000000..6ecf0c2fd476
--- /dev/null
+++ b/net-mgmt/nagios-check_hp_bladechassis/pkg-descr
@@ -0,0 +1,6 @@
+check_hp_bladechassis is a plugin for the Nagios monitoring software which
+checks the hardware health of HP blade enclosures via SNMP.
+
+The plugin is only tested with the c7000 enclosure.
+
+WWW: http://folk.uio.no/trondham/software/check_hp_bladechassis.html