aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-12-22 04:30:46 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-12-22 04:30:46 +0800
commitf20486f9d47a1787a6f9b83a0337839677c89579 (patch)
tree3d6cdfcacf7aea484496c002c2c431156a5d2284 /net-mgmt
parent811cfbb57fab2ccb4c5e043547290d0a1db98822 (diff)
downloadfreebsd-ports-gnome-f20486f9d47a1787a6f9b83a0337839677c89579.tar.gz
freebsd-ports-gnome-f20486f9d47a1787a6f9b83a0337839677c89579.tar.zst
freebsd-ports-gnome-f20486f9d47a1787a6f9b83a0337839677c89579.zip
net-mgmt/nrpe3: Fix build with LibreSSL
The patch enables the configure of the port to detect LibreSSL as a valid OpenSSL Reported by: Philip Jocks <pj@netzkommune.de> Reviewed by: brnrd, zeising (maintainer) Approved by: zeising (maintainer) Sponsored by: Netzkommune GmbH Differential Revision: https://reviews.freebsd.org/D13421
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nrpe3/Makefile5
-rw-r--r--net-mgmt/nrpe3/files/patch-include_common.h.in19
2 files changed, 21 insertions, 3 deletions
diff --git a/net-mgmt/nrpe3/Makefile b/net-mgmt/nrpe3/Makefile
index 30e80bc09712..0c7364a9d644 100644
--- a/net-mgmt/nrpe3/Makefile
+++ b/net-mgmt/nrpe3/Makefile
@@ -35,9 +35,8 @@ MONPLUGINS_DESC=Use net-mgmt/monitoring-plugins
SSL_USES= ssl
SSL_CONFIGURE_ENABLE= ssl
-SSL_CONFIGURE_ON= --with-ssl=${OPENSSLDIR} \
- --with-ssl-inc=${OPENSSLINC} \
- --with-ssl-lib=${OPENSSLLIB}
+SSL_CONFIGURE_WITH= ssl=${OPENSSLBASE} ssl-inc=${OPENSSLINC} ssl-lib=${OPENSSLLIB}
+SSL_CFLAGS= -I${OPENSSLINC}
ARGS_CONFIGURE_ON= --enable-command-args
ARGS_CONFIGURE_OFF= --disable-command-args
diff --git a/net-mgmt/nrpe3/files/patch-include_common.h.in b/net-mgmt/nrpe3/files/patch-include_common.h.in
new file mode 100644
index 000000000000..71c42206830f
--- /dev/null
+++ b/net-mgmt/nrpe3/files/patch-include_common.h.in
@@ -0,0 +1,19 @@
+--- include/common.h.in.orig 2017-12-08 11:11:28 UTC
++++ include/common.h.in
+@@ -30,11 +30,16 @@
+
+ #ifdef HAVE_SSL
+ #include <@SSL_INC_PREFIX@@SSL_HDR@>
++#include <@SSL_INC_PREFIX@crypto.h>
+ # ifdef SSL_TYPE_openssl
+ # include <@SSL_INC_PREFIX@err.h>
+ # include <@SSL_INC_PREFIX@rand.h>
+ # include <@SSL_INC_PREFIX@engine.h>
++# include <@SSL_INC_PREFIX@crypto.h>
++# if defined (LIBRESSL_VERSION_NUMBER)
++# include <@SSL_INC_PREFIX@opensslfeatures.h>
++# endif
+ # endif
+ #endif
+
+ #define PROGRAM_VERSION "3.2.1"