aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /net-mgmt
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/xymon-client/Makefile2
-rw-r--r--net-mgmt/xymon-server/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/xymon-client/Makefile b/net-mgmt/xymon-client/Makefile
index 23f733b956bb..e5013f21ce0f 100644
--- a/net-mgmt/xymon-client/Makefile
+++ b/net-mgmt/xymon-client/Makefile
@@ -35,7 +35,7 @@ do-configure:
post-install:
.for i in ${CONFIG_FILES}
${CP} -np ${WWWDIR}/client/etc/${i}.DIST \
- ${WWWDIR}/client/etc/${i}
+ ${WWWDIR}/client/etc/${i} || ${TRUE}
.endfor
.include <bsd.port.mk>
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index e2a69b13662d..9072959437f3 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -101,7 +101,7 @@ post-install:
.endfor
.for i in ${CONFIG_FILES}
${CP} -np ${WWWDIR}/server/etc/${i}.DIST \
- ${WWWDIR}/server/etc/${i}
+ ${WWWDIR}/server/etc/${i} || ${TRUE}
.endfor
.include <bsd.port.mk>