aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-10-19 02:08:32 +0800
committerpi <pi@FreeBSD.org>2016-10-19 02:08:32 +0800
commit78539f41719bf88c35c3b841407ab0e437252589 (patch)
tree62a4820f6a6fa420d58c552ce410206beffce8fe /net-mgmt
parentc9b25cea4edafd59b8cda9769fac844018d21548 (diff)
downloadfreebsd-ports-gnome-78539f41719bf88c35c3b841407ab0e437252589.tar.gz
freebsd-ports-gnome-78539f41719bf88c35c3b841407ab0e437252589.tar.zst
freebsd-ports-gnome-78539f41719bf88c35c3b841407ab0e437252589.zip
sysutils/prometheus: Fix some issues discussed in PRs
- the config file is now a @sample - pkg-plist added - /var/db/prometheus is the new place to be PR: 210059 Submitted by: Andy Carrel <wac@google.com> Approved by: jev@ecadlabs.com (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/prometheus/Makefile10
-rw-r--r--net-mgmt/prometheus/files/prometheus.in2
-rw-r--r--net-mgmt/prometheus/pkg-plist4
3 files changed, 10 insertions, 6 deletions
diff --git a/net-mgmt/prometheus/Makefile b/net-mgmt/prometheus/Makefile
index 1b763ef39035..dd42e7c2056a 100644
--- a/net-mgmt/prometheus/Makefile
+++ b/net-mgmt/prometheus/Makefile
@@ -3,6 +3,7 @@
PORTNAME= prometheus
PORTVERSION= 1.2.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
@@ -16,10 +17,6 @@ USE_GITHUB= yes
GO_PKGNAME= github.com/${PORTNAME}/${PORTNAME}
-PLIST_FILES= bin/prometheus \
- bin/promtool \
- etc/prometheus.yml
-
USE_RC_SUBR= prometheus
USERS= prometheus
@@ -31,9 +28,12 @@ do-build:
(cd ${GO_WRKSRC}/cmd/prometheus ; ${SETENV} ${GO_ENV} go install)
(cd ${GO_WRKSRC}/cmd/promtool ; ${SETENV} ${GO_ENV} go install)
+post-stage:
+ ${MKDIR} ${STAGEDIR}${DESTDIR}/var/db/prometheus
+
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/prometheus ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/promtool ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/documentation/examples/prometheus.yml ${STAGEDIR}${LOCALBASE}/etc
+ ${INSTALL_DATA} ${WRKSRC}/documentation/examples/prometheus.yml ${STAGEDIR}${LOCALBASE}/etc/prometheus.yml.sample
.include <bsd.port.mk>
diff --git a/net-mgmt/prometheus/files/prometheus.in b/net-mgmt/prometheus/files/prometheus.in
index 70c824e4984c..4f98eecf8e1e 100644
--- a/net-mgmt/prometheus/files/prometheus.in
+++ b/net-mgmt/prometheus/files/prometheus.in
@@ -14,7 +14,7 @@
# prometheus_group (string): Set group to run prometheus
# Default is "prometheus"
# prometheus_data_dir (string): Set dir to run prometheus in
-# Default is "/var/tmp/prometheus"
+# Default is "/var/db/prometheus"
# prometheus_log_file (string): Set file that prometheus will log to
# Default is "/var/log/prometheus.log"
# prometheus_args (string): Set additional command line arguments
diff --git a/net-mgmt/prometheus/pkg-plist b/net-mgmt/prometheus/pkg-plist
new file mode 100644
index 000000000000..39ce271e8e86
--- /dev/null
+++ b/net-mgmt/prometheus/pkg-plist
@@ -0,0 +1,4 @@
+bin/prometheus
+bin/promtool
+@sample etc/prometheus.yml.sample
+@dir(prometheus,prometheus) /var/db/prometheus