aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-05-27 19:22:21 +0800
committerrene <rene@FreeBSD.org>2013-05-27 19:22:21 +0800
commit8942fe5f3004019b058846ae5a77666739bf0a76 (patch)
tree397fd9a2765d35c451e5b99fb92bd7730758c146 /net-mgmt
parent821c92310398623958c4101c754f6c6536b08f68 (diff)
downloadfreebsd-ports-gnome-8942fe5f3004019b058846ae5a77666739bf0a76.tar.gz
freebsd-ports-gnome-8942fe5f3004019b058846ae5a77666739bf0a76.tar.zst
freebsd-ports-gnome-8942fe5f3004019b058846ae5a77666739bf0a76.zip
- Convert Makefile header
- Convert to optionsNG PR: ports/178427 Submitted by: rum1cro@yandex.ru Approved by: maintainer (5u623l20@gmail.com)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/flow-tools/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 415e82d9510c..40a552258f1c 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: flow-tools
-# Date created: 2000 Jul 25
-# Whom: @BABOLO <.@babolo.ru>
-#
+# Created by: @BABOLO <.@babolo.ru>
# $FreeBSD$
-#
PORTNAME= flow-tools
PORTVERSION= 0.68
@@ -16,9 +12,7 @@ COMMENT= Suite of tools and library to work with netflow data
PORTSCOUT= skipv:0.411
-OPTIONS= MYSQL "Enable MySQL support" off \
- OPENSSL "Enable OpenSSL support" off \
- PGSQL "Enable PostgreSQL support" off
+OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
CONFLICTS= flow-tools-ng-[0-9]*
@@ -52,19 +46,19 @@ FLOW_CAPTURE_UID= 174
FLOW_CAPTURE_GID= 174
FLOW_CAPTURE_PIDDIR= ${VARDIR}/run/flow-capture
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
CONFIGURE_ARGS+=--with-pgsql="${PREFIX}"
USE_PGSQL= yes
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+=--with-mysql="${PREFIX}"
USE_MYSQL= yes
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+=--with-openssl="${OPENSSLBASE}"
.endif
@@ -85,4 +79,4 @@ post-install:
@${SETENV} ${SCRIPTS_ENV} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>