aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-05-31 17:05:35 +0800
committergabor <gabor@FreeBSD.org>2007-05-31 17:05:35 +0800
commit8e7f3f9ce52d9b4bac6436480ee76e1808eb102c (patch)
treee367a5585bf7fe1f4dd764375b3f659479d443ea /net-mgmt
parentb8f02cfc2a5a7d3ce64e0bc7ce915e2df48ba862 (diff)
downloadfreebsd-ports-gnome-8e7f3f9ce52d9b4bac6436480ee76e1808eb102c.tar.gz
freebsd-ports-gnome-8e7f3f9ce52d9b4bac6436480ee76e1808eb102c.tar.zst
freebsd-ports-gnome-8e7f3f9ce52d9b4bac6436480ee76e1808eb102c.zip
Network Weathermap is a perl tool that displays in a visual way the utilization
of the network links of your network. The required data are acquired from graphs created by the MRTG package and are displayed as two ways colored arrows on a map representing the logical topology of the network. The resulted image is presented in a web page using extra DHTML and JavaScript code for web-over pop-ups, based on the OverLib JavaScript library. WWW: http://netmon.grnet.gr/weathermap/ Submitted by: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br> (via private mail)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/weathermap/Makefile60
-rw-r--r--net-mgmt/weathermap/distinfo3
-rw-r--r--net-mgmt/weathermap/files/pkg-message.in14
-rw-r--r--net-mgmt/weathermap/pkg-descr8
-rw-r--r--net-mgmt/weathermap/pkg-plist11
6 files changed, 97 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 51d91bcd449c..b36f573bed87 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -216,6 +216,7 @@
SUBDIR += trafd
SUBDIR += vidalia
SUBDIR += wdiag
+ SUBDIR += weathermap
SUBDIR += weplab
SUBDIR += whatmask
SUBDIR += wide-dhcp
diff --git a/net-mgmt/weathermap/Makefile b/net-mgmt/weathermap/Makefile
new file mode 100644
index 000000000000..2d43c162e556
--- /dev/null
+++ b/net-mgmt/weathermap/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: weathermap
+# Date created: 2007-05-03
+# Whom: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weathermap
+PORTVERSION= 1.1.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://netmon.grnet.gr/weathermap/dist/
+
+MAINTAINER= lippe@freebsdbrasil.com.br
+COMMENT= This tool displays the utilization of the network links
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+RUN_DEPENDS= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/${PERL_ARCH}/GD/Image.pm:${PORTSDIR}/graphics/p5-GD \
+ mrtg:${PORTSDIR}/net-mgmt/mrtg
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+OPTIONS= WGET "Enable WGET support" OFF
+
+PORTDOCS= README LICENSE INSTALL
+
+CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_WGET)
+RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ -e 's|weathermap.conf|${PREFIX}/etc/weathermap.conf|g' \
+ ${WRKSRC}/weathermap
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/weathermap ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${PREFIX}/etc/weathermap
+ @${INSTALL_DATA} ${WRKSRC}/example/* ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/example/weathermap.conf ${PREFIX}/etc/weathermap/weathermap.sample.conf
+ @[ -f ${PREFIX}/etc/weathermap/weathermap.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/example/weathermap.conf ${PREFIX}/etc/weathermap/weathermap.conf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/weathermap/distinfo b/net-mgmt/weathermap/distinfo
new file mode 100644
index 000000000000..61d881140b6b
--- /dev/null
+++ b/net-mgmt/weathermap/distinfo
@@ -0,0 +1,3 @@
+MD5 (weathermap-1.1.1.tar.gz) = 27e9c3b6c7c3a0d39be0a689cb64079f
+SHA256 (weathermap-1.1.1.tar.gz) = 7ea7ecfec6058cd59979b1f437ad736984e94f82845a422242375c8f0c1980b5
+SIZE (weathermap-1.1.1.tar.gz) = 117632
diff --git a/net-mgmt/weathermap/files/pkg-message.in b/net-mgmt/weathermap/files/pkg-message.in
new file mode 100644
index 000000000000..f74725e4af5e
--- /dev/null
+++ b/net-mgmt/weathermap/files/pkg-message.in
@@ -0,0 +1,14 @@
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+
+WeatherMap is now installed. You may have to follow this steps to make it
+work correctly:
+
+1. Check if your weathermap executable has been installed correctly:
+# ls -l %%PREFIX%%/bin/weathermap
+
+2. Edit %%PREFIX%%/bin/weathermap.
+
+3. Add this line in your crontab for make your graphs automatically:
+ */5 * * * * %%PREFIX%%/bin/weathermap > /tmp/weathermap.out 2>&1
+
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
diff --git a/net-mgmt/weathermap/pkg-descr b/net-mgmt/weathermap/pkg-descr
new file mode 100644
index 000000000000..30fee28411a7
--- /dev/null
+++ b/net-mgmt/weathermap/pkg-descr
@@ -0,0 +1,8 @@
+Network Weathermap is a perl tool that displays in a visual way the utilization
+of the network links of your network. The required data are acquired from
+graphs created by the MRTG package and are displayed as two ways colored arrows
+on a map representing the logical topology of the network. The resulted image
+is presented in a web page using extra DHTML and JavaScript code for web-over
+pop-ups, based on the OverLib JavaScript library.
+
+WWW: http://netmon.grnet.gr/weathermap/
diff --git a/net-mgmt/weathermap/pkg-plist b/net-mgmt/weathermap/pkg-plist
new file mode 100644
index 000000000000..e6d6fab3bd54
--- /dev/null
+++ b/net-mgmt/weathermap/pkg-plist
@@ -0,0 +1,11 @@
+bin/weathermap
+%%EXAMPLESDIR%%/weathermap.conf
+%%EXAMPLESDIR%%/weathermap.html
+%%EXAMPLESDIR%%/weathermap.png
+%%EXAMPLESDIR%%/overlib_mini.js
+%%EXAMPLESDIR%%/weathermap-background.png
+%%EXAMPLESDIR%%/weathermap-overlib.html
+@unexec if cmp -s %%PREFIX%%/etc/weathermap/weathermap.conf %%PREFIX%%/etc/weathermap/weathermap.sample.conf; then rm %%PREFIX%%/etc/weathermap/weathermap.conf; fi
+etc/weathermap/weathermap.sample.conf
+@dirrmtry etc/weathermap
+@dirrm %%EXAMPLESDIR%%