aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-07-10 22:17:21 +0800
committerstas <stas@FreeBSD.org>2007-07-10 22:17:21 +0800
commitc21bcda651c8e6e72b6b60d29aca7b8b6927f12a (patch)
treebfa5bd2e93ae1feefbb8a93f4b3149e67c1e71c9 /net-mgmt
parentb6aa101a36d44b5a570b78b0d6456d8882d802b4 (diff)
downloadfreebsd-ports-gnome-c21bcda651c8e6e72b6b60d29aca7b8b6927f12a.tar.gz
freebsd-ports-gnome-c21bcda651c8e6e72b6b60d29aca7b8b6927f12a.tar.zst
freebsd-ports-gnome-c21bcda651c8e6e72b6b60d29aca7b8b6927f12a.zip
- Add patch to fix an excess comma problem when exporting flows to SQL or
ASCII format. See the following url for further info: http://www.mail-archive.com/flow-tools@list.splintered.net/msg01034.html - Bump portrevision. Submitted by: Vladimir Zorin <vladimir@braveduck.spb.ru>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/flow-tools/Makefile2
-rw-r--r--net-mgmt/flow-tools/files/patch-src_flow-export.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 20313fe66e27..89719fcd7a59 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
diff --git a/net-mgmt/flow-tools/files/patch-src_flow-export.c b/net-mgmt/flow-tools/files/patch-src_flow-export.c
new file mode 100644
index 000000000000..bd53fcff6114
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-src_flow-export.c
@@ -0,0 +1,11 @@
+--- src/flow-export.c.orig Tue Jul 10 17:59:28 2007
++++ src/flow-export.c Tue Jul 10 18:00:22 2007
+@@ -961,7 +961,7 @@
+
+ int fmt_xfields_type(char *buf, u_int64 xfield)
+ {
+- int comma;
++ int comma = 0;
+
+ buf[0] = 0;
+