aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2013-08-07 06:36:56 +0800
committerlme <lme@FreeBSD.org>2013-08-07 06:36:56 +0800
commit09993e9d6aa33e6597ffc5713de9f688d1f571d0 (patch)
treea0dbfd9fd7630166bf4b66ca37b8e8b49d7a6350 /net-mgmt
parentd154f5b200debdbb59c4c051c2b6bdca467de5aa (diff)
downloadfreebsd-ports-gnome-09993e9d6aa33e6597ffc5713de9f688d1f571d0.tar.gz
freebsd-ports-gnome-09993e9d6aa33e6597ffc5713de9f688d1f571d0.tar.zst
freebsd-ports-gnome-09993e9d6aa33e6597ffc5713de9f688d1f571d0.zip
- Fix plist so that /var/{log,spool}/icinga are included in the package
- Drop unconditional dependency on Perl - Remove unneeded chmod g+s on the rw directory as this is the default behaviour on FreeBSD - Bump PORTREVISION
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icinga/Makefile5
-rw-r--r--net-mgmt/icinga/pkg-plist15
2 files changed, 17 insertions, 3 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 4ddd9a834659..4f44b488987d 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -3,6 +3,7 @@
PORTNAME= icinga
PORTVERSION= 1.9.3
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -15,7 +16,6 @@ LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
USES= iconv
-USE_PERL5_BUILD= yes
USE_AUTOTOOLS= autoconf libltdl
USE_RC_SUBR= icinga
@@ -90,7 +90,7 @@ APACHE_DESC= Depend on Apache and install webconfig
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMBEDDED_PERL}
-USE_PERL5= yes
+USE_PERL5_BUILD= yes
CONFIGURE_ARGS+= --enable-embedded-perl \
--with-perlcache
PLIST_SUB+= EMBEDDED_PERL=""
@@ -156,7 +156,6 @@ post-install:
.endif
@${CHMOD} 775 ${ICINGADIR} ${ICINGALOGDIR}/archives \
${ICINGADIR}/checkresults ${ICINGADIR}/rw
- @${CHMOD} g+s ${ICINGADIR}/rw
@${CHOWN} ${ICINGAUSER}:${ICINGAGROUP} ${ICINGADIR} \
${ICINGALOGDIR}/archives ${ICINGADIR}/checkresults
@${CHOWN} ${ICINGAUSER}:${WWWGRP} ${ICINGADIR}/rw
diff --git a/net-mgmt/icinga/pkg-plist b/net-mgmt/icinga/pkg-plist
index 98abbac7ffa8..51a3774db79b 100644
--- a/net-mgmt/icinga/pkg-plist
+++ b/net-mgmt/icinga/pkg-plist
@@ -1,3 +1,10 @@
+@exec mkdir -p %D/%%ICINGAWWWDIR%%/ssi
+@exec mkdir -p %%ICINGALOGDIR%%/archives
+@exec mkdir -p %%ICINGADIR%%/checkresults
+@exec mkdir -p %%ICINGADIR%%/rw
+@exec chmod 775 %%ICINGADIR%% %%ICINGALOGDIR%%/archives %%ICINGADIR%%/checkresults %%ICINGADIR%%/rw
+@exec chown %%ICINGAUSER%%:%%ICINGAGROUP%% %%ICINGADIR%% %%ICINGALOGDIR%%/archives %%ICINGADIR%%/checkresults
+@exec chown %%ICINGAUSER%%:%%WWWGRP%% %%ICINGADIR%%/rw
bin/icinga
bin/icingastats
%%IDOUTILS%%bin/ido2db
@@ -877,3 +884,11 @@ libexec/icinga/eventhandlers/submit_check_result
@dirrm etc/icinga/modules
@dirrm etc/icinga/conf.d
@dirrm etc/icinga
+@dirrmtry %%ICINGALOGDIR%%/archives
+@dirrmtry %%ICINGALOGDIR%%
+@dirrmtry %%ICINGADIR%%/checkresults
+@dirrmtry %%ICINGADIR%%/rw
+@dirrmtry %%ICINGADIR%%
+@unexec if [ -d %%ICINGADIR%% ]; then echo "==> If you are permanently removing this port, you should do a ``rm -rf %%ICINGADIR%%`` to remove any files left behind."; fi
+@unexec if [ -d %%ICINGALOGDIR%% ]; then echo "==> If you are permanently removing this port, you should do a ``rm -rf %%ICINGADIR%%`` to remove any files left behind."; fi
+@unexec if [ -d %%ETCDIR%% ]; then echo "==> If you are permanently removing this port, you should do a ``rm -rf %%ETCDIR%%`` to remove any configuration files."; fi