aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-23 14:04:01 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-23 14:04:01 +0800
commit2e5a089158bc145f89582021e74d01797d009897 (patch)
treef579cbe02fdbd28a1f909c61649a01ccee65bb50 /net-mgmt
parentf3cdfeb23d80a8c403d671681536a62f5c7dd3b0 (diff)
downloadfreebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.tar.gz
freebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.tar.zst
freebsd-ports-gnome-2e5a089158bc145f89582021e74d01797d009897.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39668 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/angst/Makefile4
-rw-r--r--net-mgmt/gps/Makefile3
-rw-r--r--net-mgmt/oproute/Makefile4
3 files changed, 8 insertions, 3 deletions
diff --git a/net-mgmt/angst/Makefile b/net-mgmt/angst/Makefile
index 85994007f508..2d6a4542d619 100644
--- a/net-mgmt/angst/Makefile
+++ b/net-mgmt/angst/Makefile
@@ -18,10 +18,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+USE_REINPLACE= yes
+
MAN8= angst.8
post-patch:
- @${PERL} -pi -e "s,^CC,#CC,g ; \
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
s,^CFLAGS,#CFLAGS,g ; \
s,libnet-config,${LIBNET_CONFIG},g" ${WRKSRC}/Makefile
diff --git a/net-mgmt/gps/Makefile b/net-mgmt/gps/Makefile
index ece2313172bc..0a08910782c5 100644
--- a/net-mgmt/gps/Makefile
+++ b/net-mgmt/gps/Makefile
@@ -15,12 +15,13 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s,-Wall -O3,${CFLAGS},g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s,-Wall -O3,${CFLAGS},g" ${WRKSRC}/configure
.if !defined(NOPORTDOCS)
post-install:
diff --git a/net-mgmt/oproute/Makefile b/net-mgmt/oproute/Makefile
index 18f7900b1153..fb7444b2cf9b 100644
--- a/net-mgmt/oproute/Makefile
+++ b/net-mgmt/oproute/Makefile
@@ -14,7 +14,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
+
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
.include <bsd.port.mk>