aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-25 04:54:09 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-25 04:54:09 +0800
commit4ccfe2bfee937078de2ec967be89f8daee2cbbcb (patch)
tree592fc1fc1577e8736a088f22f0a6784d280c7b1a /net-mgmt
parent28b0e7d83a38fead3cba180306ccb05800a2e316 (diff)
downloadfreebsd-ports-gnome-4ccfe2bfee937078de2ec967be89f8daee2cbbcb.tar.gz
freebsd-ports-gnome-4ccfe2bfee937078de2ec967be89f8daee2cbbcb.tar.zst
freebsd-ports-gnome-4ccfe2bfee937078de2ec967be89f8daee2cbbcb.zip
- Add centreon-clib 1.2.0
Centreon Clib is a common library for all Centreon products written in C/C++. This project provides high level implementation of many basic system mechanism. The target is to have a portable and powerful implementation. WWW: http://www.centreon.com/ PR: ports/189371 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/centreon-clib/Makefile21
-rw-r--r--net-mgmt/centreon-clib/distinfo2
-rw-r--r--net-mgmt/centreon-clib/pkg-descr6
-rw-r--r--net-mgmt/centreon-clib/pkg-plist72
5 files changed, 102 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a39a4c2b62e7..f1f2b6ad8c0b 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -33,6 +33,7 @@
SUBDIR += cacti-spine
SUBDIR += cdpd
SUBDIR += cdpr
+ SUBDIR += centreon-clib
SUBDIR += cflowd
SUBDIR += check_logfiles
SUBDIR += check_multi
diff --git a/net-mgmt/centreon-clib/Makefile b/net-mgmt/centreon-clib/Makefile
new file mode 100644
index 000000000000..b47496432479
--- /dev/null
+++ b/net-mgmt/centreon-clib/Makefile
@@ -0,0 +1,21 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= centreon-clib
+PORTVERSION= 1.2.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://download.centreon.com/centreon-clib/
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Common library of all Centreon projects written in C or C++
+
+LICENSE= AGPLv3
+
+USES= cmake
+CMAKE_SOURCE_PATH= ${WRKSRC}/build
+CMAKE_ARGS= -DWITH_PREFIX=${PREFIX} \
+ -DWITH_PREFIX_INC=${PREFIX}/include/centreon \
+ -DWITH_PKGCONFIG_DIR=${PREFIX}/libdata/pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/centreon-clib/distinfo b/net-mgmt/centreon-clib/distinfo
new file mode 100644
index 000000000000..e4ae2d39e655
--- /dev/null
+++ b/net-mgmt/centreon-clib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (centreon-clib-1.2.0.tar.gz) = 0405f5c14339403edb8c5dd357bd33061b543d9a0cd851500756bd88e2f9c5d6
+SIZE (centreon-clib-1.2.0.tar.gz) = 99049
diff --git a/net-mgmt/centreon-clib/pkg-descr b/net-mgmt/centreon-clib/pkg-descr
new file mode 100644
index 000000000000..39ac875a6059
--- /dev/null
+++ b/net-mgmt/centreon-clib/pkg-descr
@@ -0,0 +1,6 @@
+Centreon Clib is a common library for all Centreon products written in
+C/C++. This project provides high level implementation of many basic
+system mechanism. The target is to have a portable and powerful
+implementation.
+
+WWW: http://www.centreon.com/
diff --git a/net-mgmt/centreon-clib/pkg-plist b/net-mgmt/centreon-clib/pkg-plist
new file mode 100644
index 000000000000..58d5bcebe39f
--- /dev/null
+++ b/net-mgmt/centreon-clib/pkg-plist
@@ -0,0 +1,72 @@
+include/centreon/com/centreon/clib.hh
+include/centreon/com/centreon/delayed_delete.hh
+include/centreon/com/centreon/handle.hh
+include/centreon/com/centreon/handle_action.hh
+include/centreon/com/centreon/handle_listener.hh
+include/centreon/com/centreon/handle_manager.hh
+include/centreon/com/centreon/handle_manager_posix.hh
+include/centreon/com/centreon/handle_manager_win32.hh
+include/centreon/com/centreon/hash.hh
+include/centreon/com/centreon/library.hh
+include/centreon/com/centreon/library_posix.hh
+include/centreon/com/centreon/library_win32.hh
+include/centreon/com/centreon/namespace.hh
+include/centreon/com/centreon/process.hh
+include/centreon/com/centreon/process_listener.hh
+include/centreon/com/centreon/process_manager.hh
+include/centreon/com/centreon/process_manager_posix.hh
+include/centreon/com/centreon/process_manager_win32.hh
+include/centreon/com/centreon/process_posix.hh
+include/centreon/com/centreon/process_win32.hh
+include/centreon/com/centreon/shared_ptr.hh
+include/centreon/com/centreon/task.hh
+include/centreon/com/centreon/task_manager.hh
+include/centreon/com/centreon/timestamp.hh
+include/centreon/com/centreon/unique_array_ptr.hh
+include/centreon/com/centreon/unordered_hash.hh
+include/centreon/com/centreon/clib/version.hh
+include/centreon/com/centreon/concurrency/condvar.hh
+include/centreon/com/centreon/concurrency/condvar_posix.hh
+include/centreon/com/centreon/concurrency/condvar_win32.hh
+include/centreon/com/centreon/concurrency/locker.hh
+include/centreon/com/centreon/concurrency/mutex.hh
+include/centreon/com/centreon/concurrency/mutex_posix.hh
+include/centreon/com/centreon/concurrency/mutex_win32.hh
+include/centreon/com/centreon/concurrency/read_locker.hh
+include/centreon/com/centreon/concurrency/read_write_lock.hh
+include/centreon/com/centreon/concurrency/read_write_lock_posix.hh
+include/centreon/com/centreon/concurrency/read_write_lock_win32.hh
+include/centreon/com/centreon/concurrency/runnable.hh
+include/centreon/com/centreon/concurrency/semaphore.hh
+include/centreon/com/centreon/concurrency/semaphore_posix.hh
+include/centreon/com/centreon/concurrency/semaphore_win32.hh
+include/centreon/com/centreon/concurrency/thread.hh
+include/centreon/com/centreon/concurrency/thread_pool.hh
+include/centreon/com/centreon/concurrency/thread_posix.hh
+include/centreon/com/centreon/concurrency/thread_win32.hh
+include/centreon/com/centreon/concurrency/write_locker.hh
+include/centreon/com/centreon/exceptions/basic.hh
+include/centreon/com/centreon/io/directory_entry.hh
+include/centreon/com/centreon/io/file_entry.hh
+include/centreon/com/centreon/io/file_stream.hh
+include/centreon/com/centreon/logging/backend.hh
+include/centreon/com/centreon/logging/engine.hh
+include/centreon/com/centreon/logging/file.hh
+include/centreon/com/centreon/logging/logger.hh
+include/centreon/com/centreon/logging/syslogger.hh
+include/centreon/com/centreon/logging/temp_logger.hh
+include/centreon/com/centreon/misc/argument.hh
+include/centreon/com/centreon/misc/command_line.hh
+include/centreon/com/centreon/misc/get_options.hh
+include/centreon/com/centreon/misc/stringifier.hh
+lib/libcentreon_clib.so
+libdata/pkgconfig/centreon-clib.pc
+@dirrm include/centreon/com/centreon/misc
+@dirrm include/centreon/com/centreon/logging
+@dirrm include/centreon/com/centreon/io
+@dirrm include/centreon/com/centreon/exceptions
+@dirrm include/centreon/com/centreon/concurrency
+@dirrm include/centreon/com/centreon/clib
+@dirrm include/centreon/com/centreon
+@dirrm include/centreon/com
+@dirrm include/centreon