aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-11-09 16:29:46 +0800
committerclsung <clsung@FreeBSD.org>2004-11-09 16:29:46 +0800
commit7b082d608a2057f01cfc90b88b58b017c464c0ea (patch)
tree882aab4d8e36f2bc7d42511aa5dda24327ff6ccd /net-mgmt
parent8af294eb9e1fe2edb8610acb8ff10ef97e24b4ff (diff)
downloadfreebsd-ports-gnome-7b082d608a2057f01cfc90b88b58b017c464c0ea.tar.gz
freebsd-ports-gnome-7b082d608a2057f01cfc90b88b58b017c464c0ea.tar.zst
freebsd-ports-gnome-7b082d608a2057f01cfc90b88b58b017c464c0ea.zip
- Use WITH_FLOW_TOOLS to specify RUN_DEPENDS.
- Use ${LOCALBASE}. - flow-tools need zlib (so we need to add "-lz") - Bugfix for flow-tools support. PR: ports/73630 Submitted by: Gea-Suan Lin <gslin AT netnews dot NCTU dot edu dot tw>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/p5-Cflow/Makefile11
-rw-r--r--net-mgmt/p5-Cflow/files/patch-Cflow.xs11
2 files changed, 18 insertions, 4 deletions
diff --git a/net-mgmt/p5-Cflow/Makefile b/net-mgmt/p5-Cflow/Makefile
index 0e404d8801aa..4ba62e420293 100644
--- a/net-mgmt/p5-Cflow/Makefile
+++ b/net-mgmt/p5-Cflow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Cflow
PORTVERSION= 1.051
+PORTREVISION= 1
CATEGORIES= net-mgmt perl5
MASTER_SITES= http://net.doit.wisc.edu/~plonka/Cflow/
PKGNAMEPREFIX= p5-
@@ -14,11 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Analyze raw flow files written by cflowd (Cisco NetFlow data)
-.if exists(${PREFIX}/include/ftlib.h) && exists(${PREFIX}/lib/libft.a)
-CFLAGS+= -I${PREFIX}/include -DOSU
+.if defined(WITH_FLOW_TOOLS)
+LIB_DEPENDS+= ${LOCALBASE}/lib/libft.a:${PORTSDIR}/net-mgmt/flow-tools
+
+CFLAGS+= -I${LOCALBASE}/include -DOSU
CONFIGURE_ARGS+= \
- "LDDLFLAGS= -shared -L${PREFIX}/lib -lft" \
- "INC= -I${PREFIX}/include" "LDLOADLIBS= -L${PREFIX}/lib -lft"
+ "LDDLFLAGS= -shared -L${LOCALBASE}/lib -lft -lz" \
+ "INC= -I${LOCALBASE}/include" "LDLOADLIBS= -L${LOCALBASE}/lib -lft -lz"
.endif
PERL_CONFIGURE= YES
diff --git a/net-mgmt/p5-Cflow/files/patch-Cflow.xs b/net-mgmt/p5-Cflow/files/patch-Cflow.xs
new file mode 100644
index 000000000000..bb3915bf991d
--- /dev/null
+++ b/net-mgmt/p5-Cflow/files/patch-Cflow.xs
@@ -0,0 +1,11 @@
+--- Cflow.xs.old Sun Nov 7 06:42:07 2004
++++ Cflow.xs Sun Nov 7 06:42:32 2004
+@@ -759,7 +759,7 @@
+ uint32_t index;
+ # ifdef OSU /* [ */
+ struct fttime first, last;
+- if ((FILE *)0 == fp) {
++ if (0 == ftio_check_generic(&fs)) {
+ fdata = ftio_read(&fs);
+ if ((void *)0 == fdata) {
+ break;