aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2015-02-18 04:49:10 +0800
committerzi <zi@FreeBSD.org>2015-02-18 04:49:10 +0800
commit81d5c084b0a415176899e859f3efe7a966f92a40 (patch)
tree8665cf16a873bb9744be3d3ac1b623ce0d6a7034 /net-mgmt
parentf4d13d0cfa15b152c691ffecf6ce8b5182d2d304 (diff)
downloadfreebsd-ports-gnome-81d5c084b0a415176899e859f3efe7a966f92a40.tar.gz
freebsd-ports-gnome-81d5c084b0a415176899e859f3efe7a966f92a40.tar.zst
freebsd-ports-gnome-81d5c084b0a415176899e859f3efe7a966f92a40.zip
- Fix error in previous patch that was causing threads to be included in the process count
- Bump PORTREVISION
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-kthreads4
2 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 4f1aabf4b4ac..7c1f1e8043c1 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-kthreads b/net-mgmt/net-snmp/files/patch-kthreads
index fef637727bf8..30971a1d13f2 100644
--- a/net-mgmt/net-snmp/files/patch-kthreads
+++ b/net-mgmt/net-snmp/files/patch-kthreads
@@ -50,7 +50,7 @@ index d99cc7d..e853779 100644
extern int count_processes(void);
-extern int swrun_count_processes(void);
+#if USING_HOST_DATA_ACCESS_SWRUN_MODULE
-+static int count_kthreads = 1;
++static int count_kthreads = 0;
+
+static void parse_count_kthreads(const char *token, const char *line)
+{
@@ -77,7 +77,7 @@ index d99cc7d..e853779 100644
case HRSYS_PROCS:
#if USING_HOST_DATA_ACCESS_SWRUN_MODULE
- long_return = swrun_count_processes();
-+ long_return = swrun_count_processes(1);
++ long_return = swrun_count_processes(count_kthreads);
#elif USING_HOST_HR_SWRUN_MODULE
long_return = count_processes();
#else