aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-07-08 05:55:43 +0800
committerwg <wg@FreeBSD.org>2013-07-08 05:55:43 +0800
commitcd4b478f876f2a32f80e5a4bd98912257636261b (patch)
treea71e858a88d0ad3ec9ec889584e85ea37a777c05 /net-mgmt
parent152ff1e89d4706590f06bfc4ccbcda1a6bd4a66f (diff)
downloadfreebsd-ports-gnome-cd4b478f876f2a32f80e5a4bd98912257636261b.tar.gz
freebsd-ports-gnome-cd4b478f876f2a32f80e5a4bd98912257636261b.tar.zst
freebsd-ports-gnome-cd4b478f876f2a32f80e5a4bd98912257636261b.zip
net-mgmt/collectd5: fix build with PGSQL and GCRYPT
- Fix build with PGSQL and GCRYPT - Fix typo in a couple descriptions PR: ports/180370 Submitted by: brd Approved by: maintainer
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 025dc54bb7db..c19ce9b5612b 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -27,9 +27,9 @@ GCRYPT_DESC= Build with libgcrypt
JSON_DESC= Enable JSON plugins
MEMCACHEC_DESC= Enable memcachec plugin
MODBUS_DESC= Enable modbus plugin
-MYSQL_DESC= Enable mysql-basd plugins
+MYSQL_DESC= Enable mysql-based plugins
NUTUPS_DESC= Enable nut (ups) plugin
-PGSQL_DESC= Enable postgresql-basd plugins
+PGSQL_DESC= Enable postgresql-based plugins
PING_DESC= Enable ping plugin
PYTHON_DESC= Enable python-based plugins
REDIS_DESC= Enable redis-based plugins
@@ -206,6 +206,7 @@ PLIST_SUB+= DBI="@comment "
.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--with-libgcrypt=${LOCALBASE}
+LDFLAGS+= -lgcrypt
.endif
.if ${PORT_OPTIONS:MJSON}
@@ -258,7 +259,7 @@ PLIST_SUB+= NUTUPS="@comment "
.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
-CONFIGURE_ARGS+=--with-postgresql=${LOCALBASE} --enable-postgresql
+CONFIGURE_ARGS+=--with-postgresql=${LOCALBASE} --enable-postgresql --with-libpq
PLIST_SUB+= PGSQL=""
.else
PLIST_SUB+= PGSQL="@comment "