aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-10-08 17:30:28 +0800
committerdanfe <danfe@FreeBSD.org>2004-10-08 17:30:28 +0800
commitfba86e7ae0612efa7bf81ef1fa09d4dd2d096a77 (patch)
tree1fe8c952362b2655b5389dac77dcecced3dc8a17 /net-mgmt
parentfe0c7630784a2bc8cadcb175400631414070d4ef (diff)
downloadfreebsd-ports-gnome-fba86e7ae0612efa7bf81ef1fa09d4dd2d096a77.tar.gz
freebsd-ports-gnome-fba86e7ae0612efa7bf81ef1fa09d4dd2d096a77.tar.zst
freebsd-ports-gnome-fba86e7ae0612efa7bf81ef1fa09d4dd2d096a77.zip
Unbreak the build by making GCC feel better.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mbrowse/Makefile8
-rw-r--r--net-mgmt/mbrowse/files/patch-src+snmpstuff.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index e31696929beb..c77e12e9e81d 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -33,10 +33,4 @@ CONFIGURE_ENV+= LDFLAGS="`net-snmp-config --libs`" \
CONFIGURE_ARGS+= --with-snmp-type=net
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/mbrowse/files/patch-src+snmpstuff.c b/net-mgmt/mbrowse/files/patch-src+snmpstuff.c
new file mode 100644
index 000000000000..fcc675af530f
--- /dev/null
+++ b/net-mgmt/mbrowse/files/patch-src+snmpstuff.c
@@ -0,0 +1,11 @@
+--- src/snmpstuff.c.orig Fri Oct 8 14:07:16 2004
++++ src/snmpstuff.c Fri Oct 8 14:08:08 2004
+@@ -359,7 +359,7 @@
+ case TYPE_NSAPADDRESS:
+ case TYPE_NETADDR:
+ case TYPE_OTHER:
+- default:
++ default: ;
+ }
+ }
+ if (type == 0) {