aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-04-13 16:24:55 +0800
committernovel <novel@FreeBSD.org>2006-04-13 16:24:55 +0800
commit0e57a981c4db0edcb3919e005146db33604dfeef (patch)
treef85df3d7d843e67dff86eaa5dda007bd22b07617 /net-mgmt
parent5060a918ca607ce829830f91c777447d59773620 (diff)
downloadfreebsd-ports-gnome-0e57a981c4db0edcb3919e005146db33604dfeef.tar.gz
freebsd-ports-gnome-0e57a981c4db0edcb3919e005146db33604dfeef.tar.zst
freebsd-ports-gnome-0e57a981c4db0edcb3919e005146db33604dfeef.zip
Add an unofficial Google Map support.
Submitted by: "Anton A. Karpov" <toxa@toxahost.ru> Approved by: Peter Thoenen (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/kismet/Makefile29
-rw-r--r--net-mgmt/kismet/distinfo3
-rw-r--r--net-mgmt/kismet/files/gpsmap-gmap-0.1.diff.patch11
-rw-r--r--net-mgmt/kismet/files/pkg-message.in10
-rw-r--r--net-mgmt/kismet/pkg-plist8
5 files changed, 59 insertions, 2 deletions
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index 67ff184d1f59..d56585f16b86 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -17,7 +17,6 @@ COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS+= --enable-syspcap
@@ -25,7 +24,8 @@ CONFIGURE_ARGS+= --enable-syspcap
OPTIONS= CURSES "libcurses interface" on \
PANEL "libpanels interface" on \
SETUID "Install kismet with setuid" on \
- GPSMAP "Build gpsmap utility" on
+ GPSMAP "Build gpsmap utility" on \
+ GMAP "Build gpsmap with Google Maps patch *UNOFFICIAL*" off
.include <bsd.port.pre.mk>
@@ -53,6 +53,15 @@ BUILD_DEPENDS+= wget:${PORTSDIR}/ftp/wget
RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
.endif
+.if defined(WITH_GMAP) && !defined(WITHOUT_GPSMAP)
+PATCH_SITES= http://www.parknation.com/gmap/files/
+PATCHFILES= gpsmap-gmap-0.1.tgz
+PLIST_SUB+= GMAP=""
+SUB_FILES= pkg-message
+.else
+PLIST_SUB+= GMAP="@comment "
+.endif
+
MAN1= kismet.1 kismet_drone.1 gpsmap.1
MAN5= kismet.conf.5 kismet_drone.conf.5 kismet_ui.conf.5
@@ -61,10 +70,26 @@ CONFIGURE_ARGS+= --disable-pcap
.endif
post-extract:
+.if defined(WITH_GMAP) && !defined(WITHOUT_GPSMAP)
+ @${TAR} -C ${WRKSRC} -xzf ${DISTDIR}/${DIST_SUBDIR}/${PATCHFILES}
+ @${PATCH} -d ${WRKSRC}/gpsmap-gmap-0.1 --forward --quiet < ${PKGDIR}/files/gpsmap-gmap-0.1.diff.patch
+ @${PATCH} -d ${WRKSRC} --forward --quiet < ${WRKSRC}/gpsmap-gmap-0.1/gpsmap-gmap-0.1.diff
+.endif
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
post-install:
+.if defined(WITH_GMAP) && !defined(WITHOUT_GPSMAP)
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/gpsmap-gmap
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/mapfiles
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/index.html ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/index.html
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/README.txt ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/README.txt
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/mapfiles/shadow.png ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/mapfiles/shadow.png
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/mapfiles/wep.png ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/mapfiles/wep.png
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/mapfiles/open.png ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/mapfiles/open.png
+ ${INSTALL_DATA} ${WRKSRC}/gpsmap-gmap-0.1/mapfiles/wpa.png ${PREFIX}/share/${PORTNAME}/gpsmap-gmap/mapfiles/wpa.png
+ @${CAT} ${PKGMESSAGE}
+.endif
${INSTALL_DATA} ${WRKSRC}/conf/kismet.conf ${PREFIX}/etc/kismet.conf.sample
${INSTALL_DATA} ${WRKSRC}/conf/kismet_drone.conf ${PREFIX}/etc/kismet_drone.conf.sample
${INSTALL_DATA} ${WRKSRC}/conf/kismet_ui.conf ${PREFIX}/etc/kismet_ui.conf.sample
diff --git a/net-mgmt/kismet/distinfo b/net-mgmt/kismet/distinfo
index 5c038da831f2..3b64cf8d40e3 100644
--- a/net-mgmt/kismet/distinfo
+++ b/net-mgmt/kismet/distinfo
@@ -1,3 +1,6 @@
MD5 (kismet-2005-08-R1.tar.gz) = 17edb7688e04dd28028d5268a77d0ce7
SHA256 (kismet-2005-08-R1.tar.gz) = 27e657212881186d356907a7c45b168e7431a2f83f3411d2a90366afccf03916
SIZE (kismet-2005-08-R1.tar.gz) = 986388
+MD5 (gpsmap-gmap-0.1.tgz) = 7c62c841ccdc187812a0fe602d92d97c
+SHA256 (gpsmap-gmap-0.1.tgz) = 66c5e9c4fed70e88d092754746014bb02071b742c23390f1ec795fd14b32317b
+SIZE (gpsmap-gmap-0.1.tgz) = 13845
diff --git a/net-mgmt/kismet/files/gpsmap-gmap-0.1.diff.patch b/net-mgmt/kismet/files/gpsmap-gmap-0.1.diff.patch
new file mode 100644
index 000000000000..5fbefbc8f2d9
--- /dev/null
+++ b/net-mgmt/kismet/files/gpsmap-gmap-0.1.diff.patch
@@ -0,0 +1,11 @@
+--- gpsmap-gmap-0.1.diff.orig Thu Apr 6 17:36:37 2006
++++ gpsmap-gmap-0.1.diff Thu Apr 6 17:36:44 2006
+@@ -430,7 +430,7 @@
+ " -v, --verbose Verbose output while running\n"
+ " -g, --config-file <file> Alternate config file\n"
+ " -o, --output <filename> Image output file\n"
+-+ " -j, --googlemaps Create a javascript file (used for gogle maps\n"
+++ " -j, --googlemaps Create a javascript file (used for google maps)\n"
+ " -f, --filter <MAC list> Comma-separated list of MACs to filter\n"
+ " -i, --invert-filter Invert filtering (ONLY draw filtered MACs)\n"
+ " -F, --typefilter <Type list> Comma-separated list of net types to filter\n"
diff --git a/net-mgmt/kismet/files/pkg-message.in b/net-mgmt/kismet/files/pkg-message.in
new file mode 100644
index 000000000000..47af5377f1d5
--- /dev/null
+++ b/net-mgmt/kismet/files/pkg-message.in
@@ -0,0 +1,10 @@
+=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
+* NOTE:
+
+You have built gpsmap with Google Maps functionality.
+This is third-party patch allows you to plot wireless networks
+using Google Maps engine. It's unsupported by Kismet authors,
+please read %%PREFIX%%/share/kismet/gpsmap-gmap/README.txt from
+step 10, or see http://www.parknation.com/gmap/
+
+=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
diff --git a/net-mgmt/kismet/pkg-plist b/net-mgmt/kismet/pkg-plist
index 78c1a2bac559..301beeb03ed6 100644
--- a/net-mgmt/kismet/pkg-plist
+++ b/net-mgmt/kismet/pkg-plist
@@ -16,5 +16,13 @@ share/kismet/wav/alert.wav
share/kismet/wav/junk_traffic.wav
share/kismet/wav/new_network.wav
share/kismet/wav/traffic.wav
+%%GMAP%%share/kismet/gpsmap-gmap/README.txt
+%%GMAP%%share/kismet/gpsmap-gmap/index.html
+%%GMAP%%share/kismet/gpsmap-gmap/mapfiles/open.png
+%%GMAP%%share/kismet/gpsmap-gmap/mapfiles/shadow.png
+%%GMAP%%share/kismet/gpsmap-gmap/mapfiles/wep.png
+%%GMAP%%share/kismet/gpsmap-gmap/mapfiles/wpa.png
+%%GMAP%%@dirrm share/kismet/gpsmap-gmap/mapfiles
+%%GMAP%%@dirrm share/kismet/gpsmap-gmap
@dirrm share/kismet/wav
@dirrm share/kismet