aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-10-04 01:27:19 +0800
committerhq <hq@FreeBSD.org>2005-10-04 01:27:19 +0800
commit47e75297810fceefab427477648cc5827c56ebab (patch)
tree20bcb865c0fe0f847fa7c8f23ac3299fbf8fbf99 /net-mgmt
parent0cca132ecdd385db9434b8298aeabff062b33feb (diff)
downloadfreebsd-ports-gnome-47e75297810fceefab427477648cc5827c56ebab.tar.gz
freebsd-ports-gnome-47e75297810fceefab427477648cc5827c56ebab.tar.zst
freebsd-ports-gnome-47e75297810fceefab427477648cc5827c56ebab.zip
PfPro is a cross-platform GUI fat client for managing configurations
for the PF firewalling system. WWW: http://pfpro.sourceforge.net/ PR: 86743 Submitted by: Adam VanderHook <acidos@bandwidth-junkies.net>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/pfpro/Makefile66
-rw-r--r--net-mgmt/pfpro/distinfo2
-rw-r--r--net-mgmt/pfpro/files/pfpro.sh.in5
-rw-r--r--net-mgmt/pfpro/files/pkg-message.in7
-rw-r--r--net-mgmt/pfpro/pkg-descr4
-rw-r--r--net-mgmt/pfpro/pkg-plist16
7 files changed, 101 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a004c79ca5fe..04c585c876d1 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -133,6 +133,7 @@
SUBDIR += packit
SUBDIR += pads
SUBDIR += pancho
+ SUBDIR += pfpro
SUBDIR += php4-snmp
SUBDIR += php5-snmp
SUBDIR += pixilate
diff --git a/net-mgmt/pfpro/Makefile b/net-mgmt/pfpro/Makefile
new file mode 100644
index 000000000000..397fd9cfe383
--- /dev/null
+++ b/net-mgmt/pfpro/Makefile
@@ -0,0 +1,66 @@
+# Ports collection makefile for: Castor
+# Date created: 2005/05/12
+# Whom: Adam VanderHook <acidos@bandwidth-junkies.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfpro
+PORTVERSION= 0.1.1
+CATEGORIES= net-mgmt java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pfpro
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= acidos@bandwidth-junkies.net
+COMMENT= Cross-platform GUI fat client for PF
+
+BUILD_DEPENDS= ${JAVALIBDIR}/castor.jar:${PORTSDIR}/java/castor \
+ ${JAVALIBDIR}/jakarta-oro.jar:${PORTSDIR}/java/jakarta-oro \
+ ${JAVALIBDIR}/xalan.jar:${PORTSDIR}/textproc/xalan-j
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4
+USE_ANT= yes
+USE_JIKES= no
+MAKE_ENV= ANT_INCLUDE_SHARED_JARS=YES
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+BUILD_WRKSRC= ${WRKSRC}
+
+XMLDIR= ${PREFIX}/share/xml/${PORTNAME}
+XML_FILES= firewall.xsd
+
+XSLDIR= ${PREFIX}/share/xsl/${PORTNAME}
+XSL_FILES= xml2pf.xsl 001to010.xsl
+
+JARFILE= ${PORTNAME}.jar
+
+DOCS= BUGS CHANGELOG HACKING README RELNOTES
+EXAMPLES= baseline.xml workstation.xml
+
+SUB_FILES= pfpro.sh pkg-message
+SUB_LIST= XSLDIR=${XSLDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/dist
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}
+
+ @${MKDIR} ${XMLDIR}
+ cd ${WRKSRC}/xml && ${INSTALL_DATA} ${XML_FILES} ${XMLDIR}
+ @${MKDIR} ${XSLDIR}
+ cd ${WRKSRC}/xsl && ${INSTALL_DATA} ${XSL_FILES} ${XSLDIR}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/xml && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+
+ ${INSTALL_SCRIPT} ${WRKDIR}/pfpro.sh ${PREFIX}/bin/pfpro
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/pfpro/distinfo b/net-mgmt/pfpro/distinfo
new file mode 100644
index 000000000000..46850b1b7f57
--- /dev/null
+++ b/net-mgmt/pfpro/distinfo
@@ -0,0 +1,2 @@
+MD5 (pfpro-0.1.1-src.tar.gz) = a47ce78022f89e0ec4cf84433f133b6f
+SIZE (pfpro-0.1.1-src.tar.gz) = 58578
diff --git a/net-mgmt/pfpro/files/pfpro.sh.in b/net-mgmt/pfpro/files/pfpro.sh.in
new file mode 100644
index 000000000000..88467f4df9ad
--- /dev/null
+++ b/net-mgmt/pfpro/files/pfpro.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/pfpro.jar"
diff --git a/net-mgmt/pfpro/files/pkg-message.in b/net-mgmt/pfpro/files/pkg-message.in
new file mode 100644
index 000000000000..0934abe5863f
--- /dev/null
+++ b/net-mgmt/pfpro/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+UPGRADING CONFIGURATIONS
+------------------------
+If you are upgrading from an older version of PfPro you may need to update
+your configuration files. Stylesheets for this have been installed in
+%%XSLDIR%%/pfpro. See %%DOCSDIR%%/RELNOTES for more
+information.
diff --git a/net-mgmt/pfpro/pkg-descr b/net-mgmt/pfpro/pkg-descr
new file mode 100644
index 000000000000..c362ce78abaa
--- /dev/null
+++ b/net-mgmt/pfpro/pkg-descr
@@ -0,0 +1,4 @@
+PfPro is a cross-platform GUI fat client for managing configurations
+for the PF firewalling system.
+
+WWW: http://pfpro.sourceforge.net/
diff --git a/net-mgmt/pfpro/pkg-plist b/net-mgmt/pfpro/pkg-plist
new file mode 100644
index 000000000000..e127320462ce
--- /dev/null
+++ b/net-mgmt/pfpro/pkg-plist
@@ -0,0 +1,16 @@
+bin/pfpro
+%%DOCSDIR%%/BUGS
+%%DOCSDIR%%/CHANGELOG
+%%DOCSDIR%%/HACKING
+%%DOCSDIR%%/README
+%%DOCSDIR%%/RELNOTES
+%%EXAMPLESDIR%%/baseline.xml
+%%EXAMPLESDIR%%/workstation.xml
+%%JAVAJARDIR%%/pfpro.jar
+share/xml/pfpro/firewall.xsd
+share/xsl/pfpro/001to010.xsl
+share/xsl/pfpro/xml2pf.xsl
+@dirrm share/xsl/pfpro
+@dirrm share/xml/pfpro
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%