aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-11-14 16:23:14 +0800
committermiwi <miwi@FreeBSD.org>2007-11-14 16:23:14 +0800
commit7626b0bf328c3dc6ff4bb233cf6ded529884dbd6 (patch)
treed9502b6eca4181700e1d71bbc6ba710777a8e7aa /net-mgmt
parenta1dc2edb9b6e6bd5062d3cca1e374a3cf8753478 (diff)
downloadfreebsd-ports-gnome-7626b0bf328c3dc6ff4bb233cf6ded529884dbd6.tar.gz
freebsd-ports-gnome-7626b0bf328c3dc6ff4bb233cf6ded529884dbd6.tar.zst
freebsd-ports-gnome-7626b0bf328c3dc6ff4bb233cf6ded529884dbd6.zip
- Fix build with gcc 4.2
PR: 118009 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (linimon)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/arts++/Makefile8
-rw-r--r--net-mgmt/arts++/files/patch-classes-include_ArtsHeader.hh19
-rw-r--r--net-mgmt/arts++/files/patch-classes-include_ArtsPortMatrixAggregator.hh10
-rw-r--r--net-mgmt/arts++/files/patch-classes-include_ArtsSelectedPortTable.hh11
4 files changed, 41 insertions, 7 deletions
diff --git a/net-mgmt/arts++/Makefile b/net-mgmt/arts++/Makefile
index 938e87c4b383..9e3dea9fa2ab 100644
--- a/net-mgmt/arts++/Makefile
+++ b/net-mgmt/arts++/Makefile
@@ -24,12 +24,6 @@ MANL= artsportagg.l artsports.l artsprotos.l artsnets.l artsdump.l \
artsasagg.l artsportms.l artsportmagg.l artsintfms.l \
artsintfmagg.l artsnexthops.l artsnexthopagg.l artstos.l
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
@@ -47,4 +41,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/arts++/files/patch-classes-include_ArtsHeader.hh b/net-mgmt/arts++/files/patch-classes-include_ArtsHeader.hh
new file mode 100644
index 000000000000..2f8b227bb5aa
--- /dev/null
+++ b/net-mgmt/arts++/files/patch-classes-include_ArtsHeader.hh
@@ -0,0 +1,19 @@
+--- classes/include/ArtsHeader.hh.orig 2007-11-12 16:12:56.000000000 +0100
++++ classes/include/ArtsHeader.hh 2007-11-12 16:14:55.000000000 +0100
+@@ -421,14 +421,14 @@
+ //.........................................................................
+ //! Reads the ARTS header from an istream.
+ //-------------------------------------------------------------------------
+- std::istream& ArtsHeader::read(std::istream& is);
++ std::istream& read(std::istream& is);
+
+ //-------------------------------------------------------------------------
+ // int ArtsHeader::read(int fd)
+ //.........................................................................
+ //! Reads the ARTS header from a file descriptor.
+ //-------------------------------------------------------------------------
+- int ArtsHeader::read(int fd);
++ int read(int fd);
+
+
+ //-------------------------------------------------------------------------
diff --git a/net-mgmt/arts++/files/patch-classes-include_ArtsPortMatrixAggregator.hh b/net-mgmt/arts++/files/patch-classes-include_ArtsPortMatrixAggregator.hh
new file mode 100644
index 000000000000..6a3882fc8197
--- /dev/null
+++ b/net-mgmt/arts++/files/patch-classes-include_ArtsPortMatrixAggregator.hh
@@ -0,0 +1,10 @@
+--- classes/include/ArtsPortMatrixAggregator.hh.orig 2007-11-12 16:17:18.000000000 +0100
++++ classes/include/ArtsPortMatrixAggregator.hh 2007-11-12 16:17:28.000000000 +0100
+@@ -166,7 +166,6 @@
+ //
+ //--------------------------------------------------------------------------
+ ArtsSelectedPortTable *
+- ArtsPortMatrixAggregator::
+ ConvertToArtsSelectedPortTable(int numTopPorts,
+ bool byPkts = false) const;
+
diff --git a/net-mgmt/arts++/files/patch-classes-include_ArtsSelectedPortTable.hh b/net-mgmt/arts++/files/patch-classes-include_ArtsSelectedPortTable.hh
new file mode 100644
index 000000000000..32640f8cc149
--- /dev/null
+++ b/net-mgmt/arts++/files/patch-classes-include_ArtsSelectedPortTable.hh
@@ -0,0 +1,11 @@
+--- classes/include/ArtsSelectedPortTable.hh.orig 2007-11-12 16:16:29.000000000 +0100
++++ classes/include/ArtsSelectedPortTable.hh 2007-11-12 16:16:57.000000000 +0100
+@@ -131,7 +131,7 @@
+ //.........................................................................
+ //! Returns a reference to the ArtsPortChooser in the object.
+ //-------------------------------------------------------------------------
+- ArtsPortChooser & ArtsSelectedPortTable::PortChooser() const;
++ ArtsPortChooser & PortChooser() const;
+
+ //-------------------------------------------------------------------------
+ // std::vector<ArtsPortTableEntry> & PortEntries() const