aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2009-05-13 20:25:09 +0800
committersem <sem@FreeBSD.org>2009-05-13 20:25:09 +0800
commit8685cd27ab7bdbdb242e4d0409e28bf3610c0a14 (patch)
treecb126561df908d3f411d31f64d2e40789cc0d64b /net-mgmt
parent4cebedc9cb0daf358a3f89b55288f848a50d30b1 (diff)
downloadfreebsd-ports-gnome-8685cd27ab7bdbdb242e4d0409e28bf3610c0a14.tar.gz
freebsd-ports-gnome-8685cd27ab7bdbdb242e4d0409e28bf3610c0a14.tar.zst
freebsd-ports-gnome-8685cd27ab7bdbdb242e4d0409e28bf3610c0a14.zip
- add an option to disable embedded perl, but build perl modules
Submitted by: Boris Lytochkin <lytboris@yandex-team.ru> Approved by: maintainer timeout
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile10
-rw-r--r--net-mgmt/net-snmp/Makefile10
2 files changed, 16 insertions, 4 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index e05c730fc1ba..d4445bd2dddb 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.4.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF
MASTER_SITE_SUBDIR= net-snmp
@@ -20,6 +20,7 @@ COMMENT= An extendable SNMP implementation
OPTIONS= IPV6 "Build with IPv6 support" on \
MFD_REWRITES "Build with 64-bit Interface Counters" off \
PERL "Install additional perl modules" on \
+ PERL_EMBEDDED "Build embedded perl" on \
TKMIB "Install graphical MIB browser" off \
DUMMY "Enable dummy values as placeholders" on \
DMALLOC "Enable dmalloc debug memory allocator" off
@@ -61,7 +62,12 @@ PLIST_SUB+= WITH_TKMIB=""
.if defined(WITH_PERL)
USE_PERL5= yes
-CONFIGURE_ARGS+=--enable-embedded-perl --with-perl-modules
+CONFIGURE_ARGS+=--with-perl-modules
+.if defined(WITHOUT_PERL_EMBEDDED)
+CONFIGURE_ARGS+=--disable-embedded-perl
+.else
+CONFIGURE_ARGS+=--enable-embedded-perl
+.endif
PLIST_SUB+= WITH_PERL=""
.else
USE_PERL5_BUILD=yes
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index e05c730fc1ba..d4445bd2dddb 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.4.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF
MASTER_SITE_SUBDIR= net-snmp
@@ -20,6 +20,7 @@ COMMENT= An extendable SNMP implementation
OPTIONS= IPV6 "Build with IPv6 support" on \
MFD_REWRITES "Build with 64-bit Interface Counters" off \
PERL "Install additional perl modules" on \
+ PERL_EMBEDDED "Build embedded perl" on \
TKMIB "Install graphical MIB browser" off \
DUMMY "Enable dummy values as placeholders" on \
DMALLOC "Enable dmalloc debug memory allocator" off
@@ -61,7 +62,12 @@ PLIST_SUB+= WITH_TKMIB=""
.if defined(WITH_PERL)
USE_PERL5= yes
-CONFIGURE_ARGS+=--enable-embedded-perl --with-perl-modules
+CONFIGURE_ARGS+=--with-perl-modules
+.if defined(WITHOUT_PERL_EMBEDDED)
+CONFIGURE_ARGS+=--disable-embedded-perl
+.else
+CONFIGURE_ARGS+=--enable-embedded-perl
+.endif
PLIST_SUB+= WITH_PERL=""
.else
USE_PERL5_BUILD=yes