aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-02 00:32:44 +0800
committermiwi <miwi@FreeBSD.org>2008-06-02 00:32:44 +0800
commit8f070b27eedbc24b143937bbf1c43da47cedddbf (patch)
tree87f2a90a77a61fc3f9920ca62df2b0ec52340447 /net-mgmt
parent44d336d59ef8d414fdf62819616b738a07cd7ca4 (diff)
downloadfreebsd-ports-gnome-8f070b27eedbc24b143937bbf1c43da47cedddbf.tar.gz
freebsd-ports-gnome-8f070b27eedbc24b143937bbf1c43da47cedddbf.tar.zst
freebsd-ports-gnome-8f070b27eedbc24b143937bbf1c43da47cedddbf.zip
- Unbreak
- Fix build with gcc4.2 Submitted by: miwi Approved by: David Wolfskill (maintainer via private mail)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ap-utils/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index 20285750cde3..e1ba45352cde 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -17,7 +17,10 @@ COMMENT= A set of utilities to configure and monitor wireless access points
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_BZIP2= yes
-CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib"
+USE_ICONV= yes
+CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
.if !defined(WITHOUT_NLS)
@@ -29,12 +32,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
@@ -45,4 +42,4 @@ post-install:
${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>