aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-14 16:54:13 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-14 16:54:13 +0800
commita0226c7407ab8f0b09952a503576a7f698065aee (patch)
tree8ba22a971ab9b4d845b56e8399ef67af8dab29dc /net-mgmt
parent5a2a8eb6d8955939ffa19f8eb64fa821c5e77c85 (diff)
downloadfreebsd-ports-gnome-a0226c7407ab8f0b09952a503576a7f698065aee.tar.gz
freebsd-ports-gnome-a0226c7407ab8f0b09952a503576a7f698065aee.tar.zst
freebsd-ports-gnome-a0226c7407ab8f0b09952a503576a7f698065aee.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-geom/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-mgmt/nagios-geom/Makefile b/net-mgmt/nagios-geom/Makefile
index b5e18b5f5c50..8aaa9994873d 100644
--- a/net-mgmt/nagios-geom/Makefile
+++ b/net-mgmt/nagios-geom/Makefile
@@ -12,14 +12,16 @@ DISTNAME= check_geom-${PORTVERSION}
MAINTAINER= rea@FreeBSD.org
COMMENT= Nagios plug-in to get geom(8) components status
-USES= perl5
+USES= perl5 shebangfix
NO_WRKSUBDIR= yes
NO_BUILD= yes
PATCH_STRIP= -p1
-NO_STAGE= yes
+SHEBANG_FILES= check_geom
+
do-install:
- @${MKDIR} ${PREFIX}/libexec/nagios
- ${INSTALL_SCRIPT} ${WRKSRC}/check_geom ${PREFIX}/libexec/nagios
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_geom \
+ ${STAGEDIR}${PREFIX}/libexec/nagios
.include <bsd.port.mk>