aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2018-02-08 02:11:27 +0800
committerzi <zi@FreeBSD.org>2018-02-08 02:11:27 +0800
commite051b641ce94519b9c2e7e67617106cf66077628 (patch)
treefcd8f920f76e326c2ffa07092f124a674a8562a9 /net-mgmt
parentdf09be499b90189887d054d83b0c2630f426b6ad (diff)
downloadfreebsd-ports-gnome-e051b641ce94519b9c2e7e67617106cf66077628.tar.gz
freebsd-ports-gnome-e051b641ce94519b9c2e7e67617106cf66077628.tar.zst
freebsd-ports-gnome-e051b641ce94519b9c2e7e67617106cf66077628.zip
- Do not try to build under mips/mips64 as SSP is broken per r306364
Reported by: sbruno
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 21a578f1a85f..d3013316af89 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -18,6 +18,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpkg.so:ports-mgmt/pkg
+NOT_FOR_ARCHS= mips mips64
+NOT_FOR_ARCHS_REASON= SSP is currently broken on MIPS
+
OPTIONS_DEFINE= IPV6 MFD_REWRITES PERL PERL_EMBEDDED PYTHON DUMMY TKMIB \
MYSQL AX_SOCKONLY UNPRIVILEGED SMUX DOCS JAIL AX_DISABLE_TRAP \
TLS
@@ -28,7 +31,6 @@ MFD_REWRITES_DESC= Use new MFD rewrites of mib modules
PERL_EMBEDDED_DESC= Build embedded perl
DUMMY_DESC= Enable dummy values as placeholders
TKMIB_DESC= Install graphical MIB browser
-#DMALLOC_DESC= Enable dmalloc debug memory allocator
AX_SOCKONLY_DESC= Disable UDP/TCP transports for agentx
AX_DISABLE_TRAP_DESC= Disable agentx subagent code in snmptrapd
UNPRIVILEGED_DESC= Allow unprivileged users to execute net-snmp
@@ -118,13 +120,6 @@ PLIST_SUB+= WITH_PERL_EMBEDDED="@comment "
PLIST_SUB+= WITH_PERL="@comment "
.endif
-#.if ${PORT_OPTIONS:MDMALLOC}
-#LIB_DEPENDS+= libdmalloc.so:devel/dmalloc
-#CONFIGURE_ARGS+=--with-dmalloc=${LOCALBASE}
-#.else
-#CONFIGURE_ARGS+=--without-dmalloc
-#.endif
-
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql