aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-14 00:40:44 +0800
committermarino <marino@FreeBSD.org>2016-09-14 00:40:44 +0800
commitfc463befdf77b9d62afeed392bd56616860736af (patch)
tree2f0eecac6445bb7df610dafcb73f5510f1562c4e /net-mgmt
parentd640462b52eddc6966e9f33e742b13918460f975 (diff)
downloadfreebsd-ports-gnome-fc463befdf77b9d62afeed392bd56616860736af.tar.gz
freebsd-ports-gnome-fc463befdf77b9d62afeed392bd56616860736af.tar.zst
freebsd-ports-gnome-fc463befdf77b9d62afeed392bd56616860736af.zip
net-mgmt/nsca-ng(-client): Configure any SSL base, IGNORE LibreSSL
These ports currently utilize PSK which is not supported by LibreSSL, so detect that SSL_DEFAULT and set IGNORE accordingly. The obsolete USE_OPENSSL_PORT logic was also removed. Approved by: SSL blanket
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nsca-ng/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/nsca-ng/Makefile b/net-mgmt/nsca-ng/Makefile
index 5ac16faef6b3..807549e76167 100644
--- a/net-mgmt/nsca-ng/Makefile
+++ b/net-mgmt/nsca-ng/Makefile
@@ -20,23 +20,23 @@ LIB_DEPENDS+= libconfuse.so:devel/libconfuse
CONFLICTS?= nsca-2.* nsca27-2.*
+USES= ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/spool/nagios
-USE_OPENSSL= yes
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
.if !defined(PKGNAMESUFFIX)
USE_RC_SUBR= nsca-ng
CONFIGURE_ARGS+= --enable-server
.endif
-PORTDOCS= NEWS COPYING README PROTOCOL TODO
+PORTDOCS= NEWS COPYING README PROTOCOL TODO
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000
-WITH_OPENSSL_PORT= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+.if ${SSL_DEFAULT:Mlibressl*}
+IGNORE= Requires PSK which is unsupported by the selected LibreSSL
.endif
post-install:
@@ -61,4 +61,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>