aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2014-07-02 00:24:15 +0800
committervg <vg@FreeBSD.org>2014-07-02 00:24:15 +0800
commit479269124a300801f0fca2766c8ec734bf3a42c4 (patch)
treecbb8440e9f2eb2ebcd0d70574fa097b747705a2a /net-mgmt
parent8acd71dbaa1471c20df435c736fe8e6be9ebecd5 (diff)
downloadfreebsd-ports-gnome-479269124a300801f0fca2766c8ec734bf3a42c4.tar.gz
freebsd-ports-gnome-479269124a300801f0fca2766c8ec734bf3a42c4.tar.zst
freebsd-ports-gnome-479269124a300801f0fca2766c8ec734bf3a42c4.zip
add new port: net-mgmt/sx
Skylable Sx is a reliable, fully distributed cluster solution for your data storage needs. With Sx you can aggregate the disk space available on multiple servers and merge it into a single storage system. The cluster makes sure that your data is always replicated over multiple nodes (the exact number of copies is defined by the sysadmin) and synchronized. Additionally Sx has built-in support for deduplication, client-side encryption, on-the-fly compression and much more. WWW: http://www.skylable.com/
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/sx/Makefile42
-rw-r--r--net-mgmt/sx/distinfo2
-rw-r--r--net-mgmt/sx/files/pkg-message.in7
-rw-r--r--net-mgmt/sx/files/sxserver.in51
-rw-r--r--net-mgmt/sx/pkg-descr9
-rw-r--r--net-mgmt/sx/pkg-plist54
7 files changed, 166 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 58bf01304940..b82bd1bd863f 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -314,6 +314,7 @@
SUBDIR += ssgless
SUBDIR += statsd
SUBDIR += subcalc
+ SUBDIR += sx
SUBDIR += sysmon
SUBDIR += tcpreplay
SUBDIR += tcptrack
diff --git a/net-mgmt/sx/Makefile b/net-mgmt/sx/Makefile
new file mode 100644
index 000000000000..6108b78488f9
--- /dev/null
+++ b/net-mgmt/sx/Makefile
@@ -0,0 +1,42 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sx
+PORTVERSION= 0.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://cdn.skylable.com/source/
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= Skylable Sx is a reliable, fully distributed cluster solution
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libfcgi.so:${PORTSDIR}/www/fcgi
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= gmake libtool pkgconfig
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" --prefix="${STAGE}${PREFIX}" \
+ --sysconfdir="${ETCDIR}"
+
+OPTIONS_DEFINE= SXSERVER
+SXSERVER_DESC= Enable sxhttpd server
+OPTIONS_DEFAULT=SXSERVER
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSXSERVER}
+CONFIGURE_ARGS+=--localstatedir="${STAGE}${PREFIX}/sxserver"
+PLIST_SUB+= SXSERVER=""
+PLIST_SUB+= SXCLIENT="@comment "
+USE_RC_SUBR= sxserver
+SUB_FILES= pkg-message
+.else
+CONFIGURE_ARGS+=--disable-sxhttpd
+PLIST_SUB+= SXSERVER="@comment "
+PLIST_SUB+= SXCLIENT=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/sx/distinfo b/net-mgmt/sx/distinfo
new file mode 100644
index 000000000000..e9a1920968e9
--- /dev/null
+++ b/net-mgmt/sx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sx-0.3.tar.gz) = f176c629b3a8352f776d68612a178a46f5059427c6c48d7fa704e1044c44798f
+SIZE (sx-0.3.tar.gz) = 6529595
diff --git a/net-mgmt/sx/files/pkg-message.in b/net-mgmt/sx/files/pkg-message.in
new file mode 100644
index 000000000000..32d4e1af3cb7
--- /dev/null
+++ b/net-mgmt/sx/files/pkg-message.in
@@ -0,0 +1,7 @@
+#########################################################
+#
+#
+# After install run <sxsetup> and fill required fields
+#
+#
+#########################################################
diff --git a/net-mgmt/sx/files/sxserver.in b/net-mgmt/sx/files/sxserver.in
new file mode 100644
index 000000000000..3bb98fd1cedd
--- /dev/null
+++ b/net-mgmt/sx/files/sxserver.in
@@ -0,0 +1,51 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: sxserver
+# REQUIRE: LOGIN
+# BEFORE: securelevel
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable `sxserver':
+#
+# sxserver_enable="YES"
+#
+
+. /etc/rc.subr
+
+name="sxserver"
+rcvar=sxserver_enable
+
+command="%%PREFIX%%/sbin/sxserver"
+start_precmd="${name}_prestart"
+stop_cmd="${name}_stop"
+restart_cmd="${name}_restart"
+status_cmd="${name}_status"
+
+load_rc_config "$name"
+: ${sxserver_enable="NO"}
+
+sxserver_prestart()
+{
+ command_args="start"
+}
+
+sxserver_stop()
+{
+ eval "${command} stop"
+}
+
+sxserver_restart()
+{
+ eval "${command} restart"
+}
+
+sxserver_status()
+{
+ eval "${command} status"
+}
+
+run_rc_command $*
+
diff --git a/net-mgmt/sx/pkg-descr b/net-mgmt/sx/pkg-descr
new file mode 100644
index 000000000000..0b0cc4055afe
--- /dev/null
+++ b/net-mgmt/sx/pkg-descr
@@ -0,0 +1,9 @@
+Skylable Sx is a reliable, fully distributed cluster solution for your data
+storage needs. With Sx you can aggregate the disk space available on multiple
+servers and merge it into a single storage system. The cluster makes sure that
+your data is always replicated over multiple nodes (the exact number of copies
+is defined by the sysadmin) and synchronized. Additionally Sx has built-in
+support for deduplication, client-side encryption, on-the-fly compression and
+much more.
+
+WWW: http://www.skylable.com/
diff --git a/net-mgmt/sx/pkg-plist b/net-mgmt/sx/pkg-plist
new file mode 100644
index 000000000000..39399224d7f9
--- /dev/null
+++ b/net-mgmt/sx/pkg-plist
@@ -0,0 +1,54 @@
+bin/randgen
+bin/sxacl
+bin/sxcat
+bin/sxcp
+bin/sxinit
+bin/sxls
+bin/sxreport-client
+bin/sxrm
+bin/sxsim
+bin/sxvol
+%%SXSERVER%%%%ETCDIR%%/sxserver/errors/414.json
+%%SXSERVER%%%%ETCDIR%%/sxserver/errors/50x.json
+%%SXSERVER%%%%ETCDIR%%/sxserver/fastcgi_params
+%%SXSERVER%%%%ETCDIR%%/sxserver/sxhttpd.conf.default
+include/sx.h
+lib/libsx.so
+lib/libsx.so.0
+lib/libsx.so.0.0.0
+lib/sxclient/libsxf_aes256-12.so
+lib/sxclient/libsxf_aes256.so
+lib/sxclient/libsxf_attribs-11.so
+lib/sxclient/libsxf_attribs.so
+lib/sxclient/libsxf_null-11.so
+lib/sxclient/libsxf_null.so
+lib/sxclient/libsxf_zcomp-10.so
+lib/sxclient/libsxf_zcomp.so
+sbin/sx.fcgi
+sbin/sxadm
+%%SXSERVER%%sbin/sxhttpd
+sbin/sxreport-server
+%%SXSERVER%%sbin/sxserver
+%%SXSERVER%%sbin/sxsetup
+%%SXSERVER%%%%PORTDOCS%%%%DOCSDIR%%/logrotate.d/sxserver
+%%SXSERVER%%%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/logrotate.d
+%%SXSERVER%%%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%SXSERVER%%@dirrmtry %%ETCDIR%%/sxserver/errors
+%%SXSERVER%%@dirrmtry %%ETCDIR%%/sxserver
+%%SXSERVER%%@dirrmtry %%ETCDIR%%
+@dirrm lib/sxclient
+%%SXSERVER%%@dirrmtry sxserver/lib/sxserver
+%%SXSERVER%%@dirrmtry sxserver/lib
+%%SXSERVER%%@dirrmtry sxserver/log/sxserver
+%%SXSERVER%%@dirrmtry sxserver/log
+%%SXSERVER%%@dirrmtry sxserver/run/sxserver
+%%SXSERVER%%@dirrmtry sxserver/run
+%%SXSERVER%%@dirrmtry sxserver/sxserver
+%%SXSERVER%%@dirrmtry sxserver
+%%SXCLIENT%%@dirrmtry var/lib/sxserver
+%%SXCLIENT%%@dirrmtry var/lib
+%%SXCLIENT%%@dirrmtry var/log/sxserver
+%%SXCLIENT%%@dirrmtry var/log
+%%SXCLIENT%%@dirrmtry var/run/sxserver
+%%SXCLIENT%%@dirrmtry var/run
+%%SXCLIENT%%@dirrmtry var