aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /net-mgmt
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mrtg-ping-probe/Makefile9
-rw-r--r--net-mgmt/mrtg-ping-probe/files/patch-mrtg-ping-probe6
2 files changed, 3 insertions, 12 deletions
diff --git a/net-mgmt/mrtg-ping-probe/Makefile b/net-mgmt/mrtg-ping-probe/Makefile
index 3bb1968b4cd8..4b3abf3f1498 100644
--- a/net-mgmt/mrtg-ping-probe/Makefile
+++ b/net-mgmt/mrtg-ping-probe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mrtg-ping-probe
PORTVERSION= 2.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.pwo.de/pub/pwo/mrtg/${PORTNAME}/
@@ -14,11 +14,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mrtg:${PORTSDIR}/net-mgmt/mrtg
FETCH_BEFORE_ARGS= -p # MASTER_SITE needs PASSIVE FTP.
-USES= perl5
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PERL%%|${PERL5}|' ${WRKSRC}/${PORTNAME}
- @${CHMOD} +x ${WRKSRC}/${PORTNAME}
+USES= perl5 shebangfix
+SHEBANG_FILES= mrtg-ping-probe
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/net-mgmt/mrtg-ping-probe/files/patch-mrtg-ping-probe b/net-mgmt/mrtg-ping-probe/files/patch-mrtg-ping-probe
index 600a64ec2fc9..10928fbb3fea 100644
--- a/net-mgmt/mrtg-ping-probe/files/patch-mrtg-ping-probe
+++ b/net-mgmt/mrtg-ping-probe/files/patch-mrtg-ping-probe
@@ -1,11 +1,5 @@
--- mrtg-ping-probe.orig 2003-09-14 03:20:24.000000000 +0900
+++ mrtg-ping-probe 2009-03-10 08:01:20.000000000 +0900
-@@ -1,4 +1,4 @@
--#!/bin/perl
-+#!%%PERL%%
- ##################################################################
- # @(#) $Id: mrtg-ping-probe,v 2.5 2003/09/13 18:04:29 pwo Exp $
- # @(#) mrtg-ping-probe release $Name: Release_2_2_0 $
@@ -284,7 +284,7 @@
# try to find packet loss