aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-12-30 02:48:03 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-12-30 02:48:03 +0800
commitbdbe6b4f9042583193c5c809cc9d23b92f3cbcee (patch)
treea3f038305cb02da2051498fb845243eb4bb4555e /net-mgmt
parentbda0e08691e0e5a5e5886fbed131ee9c68194b56 (diff)
downloadfreebsd-ports-gnome-bdbe6b4f9042583193c5c809cc9d23b92f3cbcee.tar.gz
freebsd-ports-gnome-bdbe6b4f9042583193c5c809cc9d23b92f3cbcee.tar.zst
freebsd-ports-gnome-bdbe6b4f9042583193c5c809cc9d23b92f3cbcee.zip
net-mgmt/collectd5: finish option helpers conversion
- Switch PERL and PYTHON options over and drop the bsd.port.options.mk include following r404759's update to bsd.options.mk PR: 204220 Submitted by: Krzysztof <ports@bsdserwis.com> (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index c5ec59229759..fcf8e3911523 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -186,6 +186,10 @@ OPENLDAP_USE= openldap=yes
OPENLDAP_CONFIGURE_ENABLE= openldap
OPENLDAP_CONFIGURE_WITH= libldap=${LOCALBASE}
+PERL_USES= perl5
+PERL_CONFIGURE_ENABLE= perl
+PERL_CONFIGURE_WITH= perl=${PERL} perl-bindings
+
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= postgresql
PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE} libpq
@@ -197,6 +201,10 @@ PING_LIB_DEPENDS= liboping.so:${PORTSDIR}/net/liboping
PING_CONFIGURE_ENABLE= ping
PING_CONFIGURE_WITH= liboping=${LOCALBASE}
+PYTHON_USES= python:2
+PYTHON_CONFIGURE_ENABLE= python
+PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
+
RABBITMQ_LIB_DEPENDS= librabbitmq.so:${PORTSDIR}/net/rabbitmq-c
RABBITMQ_CONFIGURE_ENABLE= rabbitmq
RABBITMQ_CONFIGURE_WITH= librabbitmq=${LOCALBASE}
@@ -313,26 +321,6 @@ CONFIGURE_ARGS+=--enable-aggregation \
INSTALL_TARGET= install-strip
SHEBANG_FILES= contrib/collection.cgi
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perl=${PERL} --with-perl-bindings --enable-perl
-PLIST_SUB+= PERL=""
-.else
-CONFIGURE_ARGS+=--without-perl --without-perl-bindings --disable-perl
-PLIST_SUB+= PERL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python:2
-CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} --enable-python
-PLIST_SUB+= PYTHON=""
-.else
-CONFIGURE_ARGS+=--without-python --disable-python
-PLIST_SUB+= PYTHON="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/-Werror//' \
${WRKSRC}/configure.ac ${WRKSRC}/src/Makefile.am \