aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-07-12 14:57:47 +0800
committerpi <pi@FreeBSD.org>2014-07-12 14:57:47 +0800
commitc30c0cb4a10d739ce4016eca3eff36b9038540d7 (patch)
tree1994974daf6a85e68ac9b990078f2007ed964cca /net-mgmt
parent2dc2e039f4e7e90d78231ebfcf0506b87e7b6813 (diff)
downloadfreebsd-ports-gnome-c30c0cb4a10d739ce4016eca3eff36b9038540d7.tar.gz
freebsd-ports-gnome-c30c0cb4a10d739ce4016eca3eff36b9038540d7.tar.zst
freebsd-ports-gnome-c30c0cb4a10d739ce4016eca3eff36b9038540d7.zip
net-mgmt/netmagis-*: support staging
PR: 191408 Submitted by: pdagog@gmail.com (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/netmagis-common/Makefile17
-rw-r--r--net-mgmt/netmagis-detecteq/pkg-plist2
-rw-r--r--net-mgmt/netmagis-metro/Makefile3
-rw-r--r--net-mgmt/netmagis-metro/pkg-plist7
-rw-r--r--net-mgmt/netmagis-topo/pkg-plist4
-rw-r--r--net-mgmt/netmagis-www/Makefile3
6 files changed, 15 insertions, 21 deletions
diff --git a/net-mgmt/netmagis-common/Makefile b/net-mgmt/netmagis-common/Makefile
index 2100e3d665cd..efb9f4f78c91 100644
--- a/net-mgmt/netmagis-common/Makefile
+++ b/net-mgmt/netmagis-common/Makefile
@@ -11,6 +11,12 @@ PKGNAMESUFFIX?= -common
MAINTAINER?= pdagog@gmail.com
COMMENT?= Netmagis common infrastructure
+# Portlint barfs about a MASTERDIR variable if the LICENSE block is defined (black magic?)
+#LICENSE= CECILL-B
+#LICENSE_NAME= CeCILL-B Free Software License Agreement
+#LICENSE_FILE= ${WRKSRC}/LICENSE
+#LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
USES= tcl:85+
USE_PGSQL= pgtcl
@@ -28,13 +34,9 @@ USE_PGSQL+= server pltcl
.endif
.if ${PKGNAMESUFFIX} == -www
-USE_APACHE= 22+
USE_TEX= tex
RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz \
- pwgen:${PORTSDIR}/sysutils/pwgen \
- ${LOCALBASE}/libexec/apache22/mod_auth_pgsql.so:${PORTSDIR}/www/mod_auth_pgsql2
-# FIXME compile apache22 with option mod_auth_ldap
-# FIXME add ap22-mod_auth_cas
+ pwgen:${PORTSDIR}/sysutils/pwgen
.endif
.if ${PKGNAMESUFFIX} == -topo
@@ -51,10 +53,13 @@ RUN_DEPENDS+= p5-DBD-Pg>0:${PORTSDIR}/databases/p5-DBD-Pg \
p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
p5-SNMP_Session>=0:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
p5-RRDTool-OO>=0:${PORTSDIR}/devel/p5-RRDTool-OO
+
+USES+= shebangfix
+SHEBANG_FILES= metro/bin/metrocreatedb metro/bin/metropoller metro/bin/metropoller-run
.endif
# Variables used in netmagis Makefiles
-MAKE_ARGS+= DESTDIR=${DESTDIR} PREFIX=${PREFIX}
+MAKE_ARGS+= DESTDIR=${STAGEDIR}${DESTDIR} PREFIX=${PREFIX}
MAKE_ARGS+= TCLSH=${TCLSH} TCLCONF=${TCL_LIBDIR}/tclConfig.sh
.if ${PKGNAMESUFFIX} == -topo || ${PKGNAMESUFFIX} == -www
diff --git a/net-mgmt/netmagis-detecteq/pkg-plist b/net-mgmt/netmagis-detecteq/pkg-plist
index a667b754fcda..c33ce3dba90f 100644
--- a/net-mgmt/netmagis-detecteq/pkg-plist
+++ b/net-mgmt/netmagis-detecteq/pkg-plist
@@ -3,4 +3,4 @@ sbin/detectconfmod
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radius/server.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radius/topo.conf
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/radius
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/net-mgmt/netmagis-metro/Makefile b/net-mgmt/netmagis-metro/Makefile
index c41b682ccecb..3512091889e9 100644
--- a/net-mgmt/netmagis-metro/Makefile
+++ b/net-mgmt/netmagis-metro/Makefile
@@ -6,12 +6,9 @@ PKGNAMESUFFIX= -metro
COMMENT= Netmagis metrology module
-MANUAL_PACKAGE_BUILD= Uses non-default version of PostgreSQL
-
MASTERDIR= ${.CURDIR}/../netmagis-common
PKGMESSAGE= ${.CURDIR}/pkg-message
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/netmagis-metro/pkg-plist b/net-mgmt/netmagis-metro/pkg-plist
index 741e99ee19a4..3590ea4ac745 100644
--- a/net-mgmt/netmagis-metro/pkg-plist
+++ b/net-mgmt/netmagis-metro/pkg-plist
@@ -34,11 +34,7 @@ www/metro/gengraph
@dirrmtry var/netmagis/metro
@dirrmtry var/netmagis
@dirrmtry var
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-@dirrmtry lib/netmagis/tmp/netmagis/lib/netmagis
-@dirrmtry lib/netmagis/tmp/netmagis/lib
-@dirrmtry lib/netmagis/tmp/netmagis
-@dirrmtry lib/netmagis/tmp
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
@dirrm lib/netmagis/probes
@dirrm lib/netmagis/plugins
@exec mkdir -p %D/var/netmagis/metro/wifi
@@ -49,4 +45,3 @@ www/metro/gengraph
@exec mkdir -p %D/var/netmagis/metro/graph
@exec mkdir -p %D/var/netmagis/metro/db
@exec mkdir -p %D/var/netmagis/metro/cache
-@exec mkdir -p %D/lib/netmagis/tmp/netmagis/lib/netmagis
diff --git a/net-mgmt/netmagis-topo/pkg-plist b/net-mgmt/netmagis-topo/pkg-plist
index 1a05bbcf5b9d..7d012a7901ab 100644
--- a/net-mgmt/netmagis-topo/pkg-plist
+++ b/net-mgmt/netmagis-topo/pkg-plist
@@ -31,8 +31,8 @@ sbin/toposendd
@dirrmtry var/netmagis
@dirrmtry var
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eqvirt
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
@dirrm lib/netmagis/topo
-@dirrm lib/netmagis
+@dirrmtry lib/netmagis
@exec mkdir -p %D/var/netmagis/eqvirt
@exec mkdir -p %D/var/netmagis/eqgen
diff --git a/net-mgmt/netmagis-www/Makefile b/net-mgmt/netmagis-www/Makefile
index ed906b3d71f0..dd8884be5d84 100644
--- a/net-mgmt/netmagis-www/Makefile
+++ b/net-mgmt/netmagis-www/Makefile
@@ -6,12 +6,9 @@ PKGNAMESUFFIX= -www
COMMENT= Netmagis web module
-MANUAL_PACKAGE_BUILD= Requires non-default version of PostgreSQL
-
MASTERDIR= ${.CURDIR}/../netmagis-common
PKGMESSAGE= ${.CURDIR}/pkg-message
PLIST= ${.CURDIR}/pkg-plist
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"