aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/amule2
diff options
context:
space:
mode:
authorlaszlof <laszlof@FreeBSD.org>2009-05-21 23:23:12 +0800
committerlaszlof <laszlof@FreeBSD.org>2009-05-21 23:23:12 +0800
commitd10a57f183cb35530f4fc8c1215be5c42ec4772c (patch)
tree5f78c6774e472e8589fad9a69c6e2aeb7461d0f0 /net-p2p/amule2
parent2585fc4062427ae9199d92a84f53bd043b6dfa57 (diff)
downloadfreebsd-ports-gnome-d10a57f183cb35530f4fc8c1215be5c42ec4772c.tar.gz
freebsd-ports-gnome-d10a57f183cb35530f4fc8c1215be5c42ec4772c.tar.zst
freebsd-ports-gnome-d10a57f183cb35530f4fc8c1215be5c42ec4772c.zip
- Add WITH_UPNP knob to "Enable Universal Plug and Play support"
PR: ports/133901 Submitted by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org> Approved by: Boris Kovalenko <boris@tagnet.ru> (maitainer)
Diffstat (limited to 'net-p2p/amule2')
-rw-r--r--net-p2p/amule2/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-p2p/amule2/Makefile b/net-p2p/amule2/Makefile
index 5483e61e039e..2a838e0ad993 100644
--- a/net-p2p/amule2/Makefile
+++ b/net-p2p/amule2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aMule
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= SF/amule
@@ -45,7 +45,8 @@ OPTIONS= OPTIMIZE "Build with optimization" on \
ALC "Compile aMule Link Creator (+GUI)" on \
AMULEDAEMON "Compile aMule daemon version - EXPERIMENTAL" off \
WXUNICODE "Enable Unicode support" on \
- GEOIP "Enable GeoIP IP2Country support" off
+ GEOIP "Enable GeoIP IP2Country support" off \
+ UPNP "Enable Universal Plug and Play support" off
DOCSDIR= ${PREFIX}/share/doc/aMule-${PORTVERSION}
PORTDOCS= ABOUT-NLS Changelog EC_Protocol.txt \
@@ -123,6 +124,13 @@ LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= --disable-geoip
.endif
+.if defined(WITH_UPNP)
+CONFIGURE_ARGS+= --with-libupnp-prefix=${LOCALBASE}
+LIB_DEPENDS+= upnp.3:${PORTSDIR}/devel/upnp
+.else
+CONFIGURE_ARGS+= --disable-upnp
+.endif
+
.if !defined(WITHOUT_WXUNICODE)
WX_UNICODE=yes
.endif