aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/amule
diff options
context:
space:
mode:
authorbar <bar@FreeBSD.org>2013-10-05 18:18:20 +0800
committerbar <bar@FreeBSD.org>2013-10-05 18:18:20 +0800
commit9f19cc1d634cc88205070d92e0b3220a9c39008f (patch)
treeafbdffe8f9d5c0418a32eae18603b88bdde5fb35 /net-p2p/amule
parent4760ea6d648d9d68054d7ff662a0e1e804156dae (diff)
downloadfreebsd-ports-gnome-9f19cc1d634cc88205070d92e0b3220a9c39008f.tar.gz
freebsd-ports-gnome-9f19cc1d634cc88205070d92e0b3220a9c39008f.tar.zst
freebsd-ports-gnome-9f19cc1d634cc88205070d92e0b3220a9c39008f.zip
Common changes:
- Use new syntax for LIB_DEPENDS - Use shebangfix for perl files - Set perl as run dependency for XAS option - Bump PORTREVISION amule-devel changes: - Fix build after perl related changes - USES gmake Approved by: rene (mentor)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index e0746f35f334..db018f04ab6d 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 2.3.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/aMule/${PORTVERSION}
DISTNAME= aMule-${PORTVERSION}
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${FLEX}:${PORTSDIR}/textproc/flex \
CONFLICTS= amule-devel-[0-9]*
USE_BZIP2= yes
-USES= bison gmake pkgconfig perl5
+USES= bison gmake pkgconfig perl5 shebangfix
USE_PERL5= build
USE_WX= 2.8
WX_CONF_ARGS= absolute
@@ -61,6 +61,8 @@ PORTDOCS= ABOUT-NLS Changelog EC_Protocol.txt INSTALL README TODO \
FLEX?= ${LOCALBASE}/bin/flex
+SHEBANG_FILES= src/utils/scripts/*.pl src/utils/xas/*.pl src/libs/ec/*.pl
+
NO_STAGE= yes
.include <bsd.port.options.mk>
@@ -119,7 +121,7 @@ PLIST_SUB+= AMULEGUI="@comment "
.if ${PORT_OPTIONS:MCAS}
CONFIGURE_ARGS+= --enable-cas
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
PLIST_SUB+= CAS=""
.else
CONFIGURE_ARGS+= --disable-cas
@@ -145,7 +147,7 @@ PLIST_SUB+= FILEVIEW="@comment "
.if ${PORT_OPTIONS:MGEOIP}
CONFIGURE_ARGS+= --enable-geoip
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
.else
CONFIGURE_ARGS+= --disable-geoip
.endif
@@ -178,7 +180,7 @@ PLIST_SUB+= PLASMAMULE="@comment "
.endif
.if ${PORT_OPTIONS:MUPNP}
-LIB_DEPENDS+= upnp:${PORTSDIR}/devel/upnp
+LIB_DEPENDS+= libupnp.so:${PORTSDIR}/devel/upnp
.else
CONFIGURE_ARGS+= --disable-upnp
.endif
@@ -204,6 +206,7 @@ WX_UNICODE= yes
.endif
.if ${PORT_OPTIONS:MXAS}
+USE_PERL5+= run
CONFIGURE_ARGS+= --enable-xas
PLIST_SUB+= XAS=""
.else
@@ -219,8 +222,6 @@ post-patch: .SILENT
-e 's/test.*-print-file-name.*`/true/' \
-e '/if.*test/s/==/=/' \
${WRKSRC}/configure
- ${FIND} ${WRKSRC} -name \*.pl -exec ${REINPLACE_CMD} \
- 's|/usr/bin/perl|${PERL}|' {} +
.if empty(PORT_OPTIONS:MDOCS)
${REINPLACE_CMD} 's/install-data-am:.*/install-data-am:/' \
${WRKSRC}/docs/Makefile.in