aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/apollon/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-04-25 16:45:55 +0800
committeredwin <edwin@FreeBSD.org>2005-04-25 16:45:55 +0800
commit8afeb1f32f56e0dd8804035e9d3727c7d92a3502 (patch)
treec7dcf57c86bf1b6210f598d26d8e62137f7a4808 /net-p2p/apollon/Makefile
parentbc1e69be4e5584011ee30b8a3c5676bbd9d4e8b4 (diff)
downloadfreebsd-ports-gnome-8afeb1f32f56e0dd8804035e9d3727c7d92a3502.tar.gz
freebsd-ports-gnome-8afeb1f32f56e0dd8804035e9d3727c7d92a3502.tar.zst
freebsd-ports-gnome-8afeb1f32f56e0dd8804035e9d3727c7d92a3502.zip
[NEW PORT] net/apollon: KDE client for giFT daemon
Apollon is a Peer-to-Peer File-Sharing Program, which uses the giFT core to connect to various networks, including OpenFT, Gnutella, FastTrack WWW: http://apollon.sourceforge.net PR: ports/75675 Submitted by: Alex Varju <freebsd-ports@varju.ca>
Diffstat (limited to 'net-p2p/apollon/Makefile')
-rw-r--r--net-p2p/apollon/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/apollon/Makefile b/net-p2p/apollon/Makefile
new file mode 100644
index 000000000000..b858e7cf3fe8
--- /dev/null
+++ b/net-p2p/apollon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: apollon
+# Date Created: 29 Dec 2004
+# Whom: Alex Varju <freebsd-ports@varju.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apollon
+PORTVERSION= 1.0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= apollon
+
+MAINTAINER= freebsd-ports@varju.ca
+COMMENT= KDE client for giFT daemon
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+
+post-patch:
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e 's/^(all:)[[:space:]]+docs-am/\1/; s/^(SUBDIRS.+)doc/\1/' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>