aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/azureus
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-01-20 20:02:43 +0800
committerlioux <lioux@FreeBSD.org>2005-01-20 20:02:43 +0800
commit8339c2f1ffe66d10d77028405efe5ea1e57b257a (patch)
treecc6e855d7107ea43f541c932e06d2b04033864f4 /net-p2p/azureus
parent652e1f30cf838e0e2878176933aa56a80431ee11 (diff)
downloadfreebsd-ports-gnome-8339c2f1ffe66d10d77028405efe5ea1e57b257a.tar.gz
freebsd-ports-gnome-8339c2f1ffe66d10d77028405efe5ea1e57b257a.tar.zst
freebsd-ports-gnome-8339c2f1ffe66d10d77028405efe5ea1e57b257a.zip
o USE_JIKES=no because jikes breaks thee build
o Have restart script use sh instead of bash (wrong path anyway) o Bump PORTREVISION
Diffstat (limited to 'net-p2p/azureus')
-rw-r--r--net-p2p/azureus/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-p2p/azureus/Makefile b/net-p2p/azureus/Makefile
index e19859afb93a..20df0e4aec5f 100644
--- a/net-p2p/azureus/Makefile
+++ b/net-p2p/azureus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= azureus
PORTVERSION= 2.2.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,7 +28,9 @@ USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_OS= native
USE_ANT= yes
+USE_JIKES= no
+USE_REINPLACE= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
@@ -68,5 +70,9 @@ post-patch:
@${SED} -E \
-e 's|%%CLASSPATH%%|${CLASSPATH}|' \
${FILESDIR}/build.xml > ${WRKSRC}/build.xml
+# bash -> sh
+ @${REINPLACE_CMD} -E \
+ -e 's|/bin/bash|${SH}|' \
+ ${WRKSRC}/com/aelitis/azureus/core/update/impl/AzureusRestarterImpl.java
.include <bsd.port.post.mk>