aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/bitcoin
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-27 21:29:34 +0800
committerswills <swills@FreeBSD.org>2012-09-27 21:29:34 +0800
commit3d9f382c04446166bd75759548c8c2559966efae (patch)
treea7c016226d663d141921099ef119a78c5f62388b /net-p2p/bitcoin
parentb52bbb454d65e3a70164532748c6deaa140a93e0 (diff)
downloadfreebsd-ports-gnome-3d9f382c04446166bd75759548c8c2559966efae.tar.gz
freebsd-ports-gnome-3d9f382c04446166bd75759548c8c2559966efae.tar.zst
freebsd-ports-gnome-3d9f382c04446166bd75759548c8c2559966efae.zip
- Update to 0.7.0
- Set submitter as maintainer Submitted by: "Robert Backhaus" <robbak@robbak.com> (private email)
Diffstat (limited to 'net-p2p/bitcoin')
-rw-r--r--net-p2p/bitcoin/Makefile8
-rw-r--r--net-p2p/bitcoin/distinfo4
-rw-r--r--net-p2p/bitcoin/files/patch-bitcoin.cpp20
-rw-r--r--net-p2p/bitcoin/files/patch-qtipcserver-cpp29
-rw-r--r--net-p2p/bitcoin/files/patch-transactiondesc.cpp12
-rw-r--r--net-p2p/bitcoin/files/patch-util.h21
6 files changed, 28 insertions, 66 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 987208008667..7e97f5e30b2e 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= bitcoin
-PORTVERSION= 0.6.3
-PORTREVISION= 3
+PORTVERSION= 0.7.0
CATEGORIES= net-p2p finance
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= robbak@robbak.com
COMMENT= Virtual Peer-to-Peer Currency Client
LIB_DEPENDS= boost_date_time:${PORTSDIR}/devel/boost-libs
@@ -22,7 +21,8 @@ OPTIONS= GUI "Build with QT3 GUI" on \
USE_GITHUB= yes
GH_ACCOUNT= bitcoin
GH_PROJECT= bitcoin
-GH_COMMIT= 6e0c5e3
+GH_COMMIT= a76c22e
+GH_TAGNAME= v${PORTVERSION}
USE_GMAKE= yes
USE_OPENSSL= yes
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index 476ad4b31dfc..4ad4558828b7 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitcoin-0.6.3.tar.gz) = b4d538bdfd0c11dd0d12896ad444bcdc04cfc98b55deca73ed951ecef03363a6
-SIZE (bitcoin-0.6.3.tar.gz) = 1362075
+SHA256 (bitcoin-0.7.0.tar.gz) = d0b5ca34c61e8fbd6dca53f2730fa3d8e3df1f7bb40d5e42f8ea4cd3bf32a221
+SIZE (bitcoin-0.7.0.tar.gz) = 1603153
diff --git a/net-p2p/bitcoin/files/patch-bitcoin.cpp b/net-p2p/bitcoin/files/patch-bitcoin.cpp
deleted file mode 100644
index d42c22427af8..000000000000
--- a/net-p2p/bitcoin/files/patch-bitcoin.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/qt/bitcoin.cpp.orig 2012-06-19 16:44:55.000000000 -0400
-+++ src/qt/bitcoin.cpp 2012-09-03 13:30:43.641710746 -0400
-@@ -134,7 +134,7 @@
- #ifndef BITCOIN_QT_TEST
- int main(int argc, char *argv[])
- {
--#if !defined(MAC_OSX) && !defined(WIN32)
-+#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
- // TODO: implement qtipcserver.cpp for Mac and Windows
-
- // Do this early as we don't want to bother initializing if we are just calling IPC
-@@ -261,7 +261,7 @@
- // Place this here as guiref has to be defined if we dont want to lose URIs
- ipcInit();
-
--#if !defined(MAC_OSX) && !defined(WIN32)
-+#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
- // TODO: implement qtipcserver.cpp for Mac and Windows
-
- // Check for URI in argv
diff --git a/net-p2p/bitcoin/files/patch-qtipcserver-cpp b/net-p2p/bitcoin/files/patch-qtipcserver-cpp
index 971002de9a42..3da8e9b209e5 100644
--- a/net-p2p/bitcoin/files/patch-qtipcserver-cpp
+++ b/net-p2p/bitcoin/files/patch-qtipcserver-cpp
@@ -1,13 +1,16 @@
---- src/qt/qtipcserver.cpp.orig 2012-06-19 16:44:55.000000000 -0400
-+++ src/qt/qtipcserver.cpp 2012-09-02 09:39:34.034704891 -0400
-@@ -50,6 +50,10 @@
- // TODO: implement bitcoin: URI handling the Mac Way
- return;
- #endif
-+#ifdef __FreeBSD__
-+ // TODO: implement bitcoin: URI handling the Mac Way
-+ return;
-+#endif
- #ifdef WIN32
- // TODO: THOROUGHLY test boost::interprocess fix,
- // and make sure there are no Windows argument-handling exploitable
+diff -ur bitcoin-bitcoin-a76c22e.orig/src/qt/qtipcserver.cpp bitcoin-bitcoin-a76c22e/src/qt/qtipcserver.cpp
+--- bitcoin-bitcoin-a76c22e.orig/src/qt/qtipcserver.cpp 2012-09-19 22:13:23.000000000 +1000
++++ src/qt/qtipcserver.cpp 2012-09-19 22:17:52.000000000 +1000
+@@ -32,6 +32,12 @@
+ void ipcScanRelay(int argc, char *argv[]) { }
+ void ipcInit(int argc, char *argv[]) { }
+
++#elif defined __FreeBSD__
++// URI handling not implemented on BSD either
++
++void ipcScanRelay(int argc, char *argv[]) { }
++void ipcInit(int argc, char *argv[]) { }
++
+ #else
+
+ static void ipcThread2(void* pArg);
diff --git a/net-p2p/bitcoin/files/patch-transactiondesc.cpp b/net-p2p/bitcoin/files/patch-transactiondesc.cpp
index eaaba020eb2e..b493196ce027 100644
--- a/net-p2p/bitcoin/files/patch-transactiondesc.cpp
+++ b/net-p2p/bitcoin/files/patch-transactiondesc.cpp
@@ -1,10 +1,10 @@
---- src/qt/transaction.cpp.orig 2012-09-01 03:08:26.000000000 +0000
-+++ src/qt/transactiondesc.cpp 2012-09-01 03:08:38.000000000 +0000
-@@ -7,6 +7,7 @@
- #include "wallet.h"
+--- src/qt/transactiondesc.cpp.orig 2012-09-13 04:07:22.000000000 +1000
++++ src/qt/transactiondesc.cpp 2012-09-19 18:44:39.000000000 +1000
+@@ -8,6 +8,7 @@
#include "db.h"
#include "ui_interface.h"
+ #include "base58.h"
+#include "walletdb.h"
- #include <QString>
-
+ QString TransactionDesc::FormatTxStatus(const CWalletTx& wtx)
+ {
diff --git a/net-p2p/bitcoin/files/patch-util.h b/net-p2p/bitcoin/files/patch-util.h
deleted file mode 100644
index 7f6f8e0df160..000000000000
--- a/net-p2p/bitcoin/files/patch-util.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/util.h.orig 2012-09-02 08:13:29.000000000 -0500
-+++ src/util.h 2012-09-02 08:14:08.000000000 -0500
-@@ -290,8 +290,6 @@
- LeaveCritical(); \
- }
-
--#ifdef MAC_OSX
--// boost::interprocess::interprocess_semaphore seems to spinlock on OSX; prefer polling instead
- class CSemaphore
- {
- private:
-@@ -328,9 +326,6 @@
- val++;
- }
- };
--#else
--typedef boost::interprocess::interprocess_semaphore CSemaphore;
--#endif
-
- inline std::string i64tostr(int64 n)
- {