aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/bitcoin
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
committermat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
commitaccc153f0c7ee632df7b714f1861b98898e90e7c (patch)
tree509f9c56f6c9e206681219518e92866874b3ae54 /net-p2p/bitcoin
parentc333a42bbacfd478a1ae703c628fc3f6f2ce3575 (diff)
downloadfreebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.gz
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.zst
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.zip
USE_BDB cleanup.
- USE_BDB=4x+ -> USES=bdb. - USE_BDB=yes -> USES=bdb. - USE_BDB=xx -> USES=bdb:xx. Other modernisations when I see them. PR: 209183 Sponsored by: Absolight
Diffstat (limited to 'net-p2p/bitcoin')
-rw-r--r--net-p2p/bitcoin/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 1c0f3d98947f..05c90b50cc29 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -14,10 +14,9 @@ LICENSE= MIT
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent2
-USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix
+USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
SLAVE_PORT?= no
@@ -70,7 +69,7 @@ QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
WALLET_CONFIGURE_ENABLE= wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
-WALLET_USE= BDB=48
+WALLET_USES= bdb:48
ZMQ_CONFIGURE_ENABLE= zmq
ZMQ_BUILD_DEPENDS= libzmq4>0:net/libzmq4