aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/dclib/Makefile
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-06-02 20:03:12 +0800
committergahr <gahr@FreeBSD.org>2008-06-02 20:03:12 +0800
commit4608da86d84416358305de3016ae1e5da5b3886e (patch)
treef54b7be68962cbf15d48d4c893edd99ec2a18148 /net-p2p/dclib/Makefile
parentba24c9623ca23638909b0af699823e552210741b (diff)
downloadfreebsd-ports-gnome-4608da86d84416358305de3016ae1e5da5b3886e.tar.gz
freebsd-ports-gnome-4608da86d84416358305de3016ae1e5da5b3886e.tar.zst
freebsd-ports-gnome-4608da86d84416358305de3016ae1e5da5b3886e.zip
- Update to 0.3.14
- Take maintainship
Diffstat (limited to 'net-p2p/dclib/Makefile')
-rw-r--r--net-p2p/dclib/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index 04977af940c6..7d9c487a89fe 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -1,3 +1,4 @@
+# ex: ts=8
# New ports collection makefile for: dclib
# Date created: Wed 10 Jul 2002
# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
@@ -7,10 +8,11 @@
#
PORTNAME= dclib
-PORTVERSION= 0.3.13
+PORTVERSION= 0.3.14
CATEGORIES= net-p2p
MASTER_SITES= SF
MASTER_SITE_SUBDIR= wxdcgui
+DISTNAME= ${PORTNAME}-${PORTVERSION}a
MAINTAINER= gahr@FreeBSD.org
COMMENT= Direct connect interface library for valknut
@@ -18,6 +20,8 @@ COMMENT= Direct connect interface library for valknut
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
xml2.5:${PORTSDIR}/textproc/libxml2
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -25,10 +29,15 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+post-extract:
+ ${CHMOD} 0755 ${WRKSRC}/admin/install-sh
+
post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
+ ${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
+ ${FIND} ${WRKSRC} -name "Makefile.*" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|dclib-0.3/||g'
.include <bsd.port.mk>