aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/deluge/files
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-06-12 15:11:07 +0800
committermezz <mezz@FreeBSD.org>2007-06-12 15:11:07 +0800
commit5f0ddc845f22f9b3ac62526179041c70c76907ad (patch)
treec527d28930a933c404e99447a18b3ae092230a39 /net-p2p/deluge/files
parent070f9a81b28b0b3c5e60fe4c81c55b79ee95ab7a (diff)
downloadfreebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.tar.gz
freebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.tar.zst
freebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.zip
Update to 0.5.1 and took a patch from rblibtorrent/files/patch-socket_ops.hpp.
Diffstat (limited to 'net-p2p/deluge/files')
-rw-r--r--net-p2p/deluge/files/patch-setup.py42
-rw-r--r--net-p2p/deluge/files/patch-socket_ops.hpp20
-rw-r--r--net-p2p/deluge/files/patch-src_interface.py (renamed from net-p2p/deluge/files/patch-src_delugegtk.py)8
3 files changed, 49 insertions, 21 deletions
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index 9fbfc5ca0639..6c14fb6018da 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,27 +1,35 @@
---- setup.py.orig Tue Mar 6 21:43:47 2007
-+++ setup.py Tue Mar 6 21:45:44 2007
-@@ -51,7 +51,7 @@
- #
+--- setup.py.orig Sat Jun 9 12:16:40 2007
++++ setup.py Sat Jun 9 12:19:31 2007
+@@ -100,7 +100,7 @@
+ else:
+ boosttype = 'mt'
+ removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
+- additions = ['-DNDEBUG', '-O2']
++ additions = ['-DNDEBUG']
- removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
--additions = ['-DNDEBUG', '-O2']
-+additions = ['-DNDEBUG']
+ if python_version == '2.5':
+ cv_opt = sysconfig.get_config_vars()["CFLAGS"]
+@@ -131,19 +131,21 @@
+ # Ubuntu possible.
+ if boosttype == "nomt":
+ librariestype = ['boost_filesystem', 'boost_date_time',
+- 'boost_thread', 'z', 'pthread', 'ssl']
++ 'boost_thread', 'z', 'ssl']
+ print 'Libraries nomt'
+ elif boosttype == "mt":
+ librariestype = ['boost_filesystem-mt', 'boost_date_time-mt',
+- 'boost_thread-mt', 'z', 'pthread', 'ssl']
++ 'boost_thread-mt', 'z', 'ssl']
+ print 'Libraries mt'
- if pythonVersion == '2.5':
- cv_opt = sysconfig.get_config_vars()["CFLAGS"]
-@@ -85,12 +85,14 @@
deluge_core = Extension('deluge_core',
include_dirs = ['./libtorrent', './libtorrent/include',
'./libtorrent/include/libtorrent',
-- '/usr/include/python' + pythonVersion],
+- '/usr/include/python' + python_version],
+ '%%LOCALBASE%%/include'],
+ library_dirs = ['%%LOCALBASE%%/lib'],
- libraries = ['boost_filesystem', 'boost_date_time',
- 'boost_program_options', 'boost_regex',
- 'boost_serialization', 'boost_thread',
-- 'z', 'pthread'],
-+ 'z'],
- extra_compile_args = ["-Wno-missing-braces"],
+ libraries = librariestype,
+ extra_compile_args = EXTRA_COMPILE_ARGS,
+ extra_link_args = ['%%PTHREAD_LIBS%%'],
sources = ['src/deluge_core.cpp',
'libtorrent/src/alert.cpp',
diff --git a/net-p2p/deluge/files/patch-socket_ops.hpp b/net-p2p/deluge/files/patch-socket_ops.hpp
new file mode 100644
index 000000000000..bffd0c853a3d
--- /dev/null
+++ b/net-p2p/deluge/files/patch-socket_ops.hpp
@@ -0,0 +1,20 @@
+--- libtorrent/include/libtorrent/asio/detail/socket_ops.hpp.orig Sun May 27 17:11:11 2007
++++ libtorrent/include/libtorrent/asio/detail/socket_ops.hpp Sun Jun 10 11:58:14 2007
+@@ -63,7 +63,7 @@
+ socket_addr_len_type* addrlen, asio::error_code& ec)
+ {
+ clear_error(ec);
+-#if defined(__MACH__) && defined(__APPLE__)
++#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ socket_type new_s = error_wrapper(::accept(s, addr, addrlen), ec);
+ if (new_s == invalid_socket)
+ return new_s;
+@@ -295,7 +295,7 @@
+ }
+
+ return s;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ socket_type s = error_wrapper(::socket(af, type, protocol), ec);
+ if (s == invalid_socket)
+ return s;
diff --git a/net-p2p/deluge/files/patch-src_delugegtk.py b/net-p2p/deluge/files/patch-src_interface.py
index 0a0bf5e99919..b878c7def432 100644
--- a/net-p2p/deluge/files/patch-src_delugegtk.py
+++ b/net-p2p/deluge/files/patch-src_interface.py
@@ -1,9 +1,9 @@
---- src/delugegtk.py.orig Tue Mar 6 20:46:00 2007
-+++ src/delugegtk.py Tue Mar 6 22:42:58 2007
-@@ -33,9 +33,9 @@
+--- src/interface.py.orig Sat Jun 9 12:20:35 2007
++++ src/interface.py Sat Jun 9 12:20:54 2007
+@@ -75,9 +75,9 @@
def __init__(self):
APP = 'deluge'
- DIR = os.path.join(dcommon.INSTALL_PREFIX, 'share', 'locale')
+ DIR = os.path.join(common.INSTALL_PREFIX, 'share', 'locale')
- locale.setlocale(locale.LC_ALL, '')
- locale.bindtextdomain(APP, DIR)
- locale.textdomain(APP)