aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/deluge/files
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-03-01 03:25:34 +0800
committermezz <mezz@FreeBSD.org>2008-03-01 03:25:34 +0800
commitc4c5c3b5d3fcd377cc3961d863510cadc7139981 (patch)
tree904fede5f631651d27d8818c77befb8a73225462 /net-p2p/deluge/files
parent8c9bc467342328494f8f4d389732eeccff452a87 (diff)
downloadfreebsd-ports-gnome-c4c5c3b5d3fcd377cc3961d863510cadc7139981.tar.gz
freebsd-ports-gnome-c4c5c3b5d3fcd377cc3961d863510cadc7139981.tar.zst
freebsd-ports-gnome-c4c5c3b5d3fcd377cc3961d863510cadc7139981.zip
Update to 0.5.8.5.
Diffstat (limited to 'net-p2p/deluge/files')
-rw-r--r--net-p2p/deluge/files/patch-libtorrent_src_enum_net.cpp10
-rw-r--r--net-p2p/deluge/files/patch-setup.py12
2 files changed, 16 insertions, 6 deletions
diff --git a/net-p2p/deluge/files/patch-libtorrent_src_enum_net.cpp b/net-p2p/deluge/files/patch-libtorrent_src_enum_net.cpp
new file mode 100644
index 000000000000..ba47faffbe7d
--- /dev/null
+++ b/net-p2p/deluge/files/patch-libtorrent_src_enum_net.cpp
@@ -0,0 +1,10 @@
+--- libtorrent/src/enum_net.cpp.orig 2008-02-29 13:02:02.000000000 -0600
++++ libtorrent/src/enum_net.cpp 2008-02-29 13:02:22.000000000 -0600
+@@ -34,6 +34,7 @@
+
+ #if defined TORRENT_BSD || defined TORRENT_LINUX
+ #include <sys/ioctl.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <net/if.h>
+ #elif defined TORRENT_WINDOWS
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index 96616853aecc..cce0a37ee814 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig 2008-01-19 12:43:31.000000000 -0600
-+++ setup.py 2008-01-19 12:45:24.000000000 -0600
+--- setup.py.orig 2008-02-29 12:23:50.000000000 -0600
++++ setup.py 2008-02-29 12:25:51.000000000 -0600
@@ -103,13 +103,13 @@
"-DHAVE_INCLUDE_LIBTORRENT_ASIO_SSL_STREAM_HPP=1",
"-DHAVE_INCLUDE_LIBTORRENT_ASIO_IP_TCP_HPP=1",
@@ -20,12 +20,12 @@
boost_thread = "boost_thread-mt"
librariestype = [boost_filesystem, boost_date_time,
-- boost_thread, 'z', 'pthread', 'ssl', 'rt', 'crypto']
+- boost_thread, 'z', 'pthread', 'ssl', 'crypto']
+ boost_thread, 'z', 'ssl', 'crypto']
-
- removals = ['-g', '-Wstrict-prototypes']
-@@ -202,8 +202,10 @@
+ if os == "linux":
+ librariestype += ['rt']
+@@ -205,8 +205,10 @@
sources.remove('libtorrent/src/file_win.cpp')
deluge_core = Extension('deluge_core',
include_dirs = includedirs,