aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/deluge05
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-06-12 15:11:07 +0800
committermezz <mezz@FreeBSD.org>2007-06-12 15:11:07 +0800
commit5f0ddc845f22f9b3ac62526179041c70c76907ad (patch)
treec527d28930a933c404e99447a18b3ae092230a39 /net-p2p/deluge05
parent070f9a81b28b0b3c5e60fe4c81c55b79ee95ab7a (diff)
downloadfreebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.tar.gz
freebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.tar.zst
freebsd-ports-gnome-5f0ddc845f22f9b3ac62526179041c70c76907ad.zip
Update to 0.5.1 and took a patch from rblibtorrent/files/patch-socket_ops.hpp.
Diffstat (limited to 'net-p2p/deluge05')
-rw-r--r--net-p2p/deluge05/Makefile8
-rw-r--r--net-p2p/deluge05/distinfo6
-rw-r--r--net-p2p/deluge05/files/patch-setup.py42
-rw-r--r--net-p2p/deluge05/files/patch-socket_ops.hpp20
-rw-r--r--net-p2p/deluge05/files/patch-src_interface.py (renamed from net-p2p/deluge05/files/patch-src_delugegtk.py)8
-rw-r--r--net-p2p/deluge05/pkg-plist34
6 files changed, 77 insertions, 41 deletions
diff --git a/net-p2p/deluge05/Makefile b/net-p2p/deluge05/Makefile
index 78a4f51ed761..bf2fe83df9c2 100644
--- a/net-p2p/deluge05/Makefile
+++ b/net-p2p/deluge05/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= deluge
-PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTVERSION= 0.5.1
CATEGORIES= net-p2p python
-MASTER_SITES= http://deluge-torrent.org/downloads/
+MASTER_SITES= http://download.deluge-torrent.org/stable/
MAINTAINER= mezz@FreeBSD.org
COMMENT= A Bittorrent client, using Python, GTK+2 and Rasterbar libtorrent
@@ -20,6 +19,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
USE_GNOME= pygtk2 desktopfileutils
USE_GETTEXT= yes
+USE_OPENSSL= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
@@ -27,7 +27,7 @@ DOCS= LICENSE README
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -DAMD64
.endif
diff --git a/net-p2p/deluge05/distinfo b/net-p2p/deluge05/distinfo
index 8b5d92bc838c..0e0cba0a2366 100644
--- a/net-p2p/deluge05/distinfo
+++ b/net-p2p/deluge05/distinfo
@@ -1,3 +1,3 @@
-MD5 (deluge-0.5.0.tar.gz) = d83e6ee573ac9e2e8d11bc3f446da3f8
-SHA256 (deluge-0.5.0.tar.gz) = 7f2f8c575f481ee623b7116e6cf9ffb314ee9e065e886478b8795ae5a6e7dfcd
-SIZE (deluge-0.5.0.tar.gz) = 518982
+MD5 (deluge-0.5.1.tar.gz) = 2455b00497eceba8b58e7bab62c008da
+SHA256 (deluge-0.5.1.tar.gz) = c39c578049bbb620de1cbe0e5bf8d0782816951cc6a389d5a8d84f57c08213df
+SIZE (deluge-0.5.1.tar.gz) = 619214
diff --git a/net-p2p/deluge05/files/patch-setup.py b/net-p2p/deluge05/files/patch-setup.py
index 9fbfc5ca0639..6c14fb6018da 100644
--- a/net-p2p/deluge05/files/patch-setup.py
+++ b/net-p2p/deluge05/files/patch-setup.py
@@ -1,27 +1,35 @@
---- setup.py.orig Tue Mar 6 21:43:47 2007
-+++ setup.py Tue Mar 6 21:45:44 2007
-@@ -51,7 +51,7 @@
- #
+--- setup.py.orig Sat Jun 9 12:16:40 2007
++++ setup.py Sat Jun 9 12:19:31 2007
+@@ -100,7 +100,7 @@
+ else:
+ boosttype = 'mt'
+ removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
+- additions = ['-DNDEBUG', '-O2']
++ additions = ['-DNDEBUG']
- removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
--additions = ['-DNDEBUG', '-O2']
-+additions = ['-DNDEBUG']
+ if python_version == '2.5':
+ cv_opt = sysconfig.get_config_vars()["CFLAGS"]
+@@ -131,19 +131,21 @@
+ # Ubuntu possible.
+ if boosttype == "nomt":
+ librariestype = ['boost_filesystem', 'boost_date_time',
+- 'boost_thread', 'z', 'pthread', 'ssl']
++ 'boost_thread', 'z', 'ssl']
+ print 'Libraries nomt'
+ elif boosttype == "mt":
+ librariestype = ['boost_filesystem-mt', 'boost_date_time-mt',
+- 'boost_thread-mt', 'z', 'pthread', 'ssl']
++ 'boost_thread-mt', 'z', 'ssl']
+ print 'Libraries mt'
- if pythonVersion == '2.5':
- cv_opt = sysconfig.get_config_vars()["CFLAGS"]
-@@ -85,12 +85,14 @@
deluge_core = Extension('deluge_core',
include_dirs = ['./libtorrent', './libtorrent/include',
'./libtorrent/include/libtorrent',
-- '/usr/include/python' + pythonVersion],
+- '/usr/include/python' + python_version],
+ '%%LOCALBASE%%/include'],
+ library_dirs = ['%%LOCALBASE%%/lib'],
- libraries = ['boost_filesystem', 'boost_date_time',
- 'boost_program_options', 'boost_regex',
- 'boost_serialization', 'boost_thread',
-- 'z', 'pthread'],
-+ 'z'],
- extra_compile_args = ["-Wno-missing-braces"],
+ libraries = librariestype,
+ extra_compile_args = EXTRA_COMPILE_ARGS,
+ extra_link_args = ['%%PTHREAD_LIBS%%'],
sources = ['src/deluge_core.cpp',
'libtorrent/src/alert.cpp',
diff --git a/net-p2p/deluge05/files/patch-socket_ops.hpp b/net-p2p/deluge05/files/patch-socket_ops.hpp
new file mode 100644
index 000000000000..bffd0c853a3d
--- /dev/null
+++ b/net-p2p/deluge05/files/patch-socket_ops.hpp
@@ -0,0 +1,20 @@
+--- libtorrent/include/libtorrent/asio/detail/socket_ops.hpp.orig Sun May 27 17:11:11 2007
++++ libtorrent/include/libtorrent/asio/detail/socket_ops.hpp Sun Jun 10 11:58:14 2007
+@@ -63,7 +63,7 @@
+ socket_addr_len_type* addrlen, asio::error_code& ec)
+ {
+ clear_error(ec);
+-#if defined(__MACH__) && defined(__APPLE__)
++#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ socket_type new_s = error_wrapper(::accept(s, addr, addrlen), ec);
+ if (new_s == invalid_socket)
+ return new_s;
+@@ -295,7 +295,7 @@
+ }
+
+ return s;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ socket_type s = error_wrapper(::socket(af, type, protocol), ec);
+ if (s == invalid_socket)
+ return s;
diff --git a/net-p2p/deluge05/files/patch-src_delugegtk.py b/net-p2p/deluge05/files/patch-src_interface.py
index 0a0bf5e99919..b878c7def432 100644
--- a/net-p2p/deluge05/files/patch-src_delugegtk.py
+++ b/net-p2p/deluge05/files/patch-src_interface.py
@@ -1,9 +1,9 @@
---- src/delugegtk.py.orig Tue Mar 6 20:46:00 2007
-+++ src/delugegtk.py Tue Mar 6 22:42:58 2007
-@@ -33,9 +33,9 @@
+--- src/interface.py.orig Sat Jun 9 12:20:35 2007
++++ src/interface.py Sat Jun 9 12:20:54 2007
+@@ -75,9 +75,9 @@
def __init__(self):
APP = 'deluge'
- DIR = os.path.join(dcommon.INSTALL_PREFIX, 'share', 'locale')
+ DIR = os.path.join(common.INSTALL_PREFIX, 'share', 'locale')
- locale.setlocale(locale.LC_ALL, '')
- locale.bindtextdomain(APP, DIR)
- locale.textdomain(APP)
diff --git a/net-p2p/deluge05/pkg-plist b/net-p2p/deluge05/pkg-plist
index f9908ec9ff1e..235d37810741 100644
--- a/net-p2p/deluge05/pkg-plist
+++ b/net-p2p/deluge05/pkg-plist
@@ -2,28 +2,31 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/__init__.py
%%PYTHON_SITELIBDIR%%/deluge/__init__.pyc
%%PYTHON_SITELIBDIR%%/deluge/__init__.pyo
-%%PYTHON_SITELIBDIR%%/deluge/dcommon.py
-%%PYTHON_SITELIBDIR%%/deluge/dcommon.pyc
-%%PYTHON_SITELIBDIR%%/deluge/dcommon.pyo
-%%PYTHON_SITELIBDIR%%/deluge/deluge.py
-%%PYTHON_SITELIBDIR%%/deluge/deluge.pyc
-%%PYTHON_SITELIBDIR%%/deluge/deluge.pyo
+%%PYTHON_SITELIBDIR%%/deluge/common.py
+%%PYTHON_SITELIBDIR%%/deluge/common.pyc
+%%PYTHON_SITELIBDIR%%/deluge/common.pyo
+%%PYTHON_SITELIBDIR%%/deluge/core.py
+%%PYTHON_SITELIBDIR%%/deluge/core.pyc
+%%PYTHON_SITELIBDIR%%/deluge/core.pyo
%%PYTHON_SITELIBDIR%%/deluge/deluge_core.so
%%PYTHON_SITELIBDIR%%/deluge/deluge_stats.py
%%PYTHON_SITELIBDIR%%/deluge/deluge_stats.pyc
%%PYTHON_SITELIBDIR%%/deluge/deluge_stats.pyo
-%%PYTHON_SITELIBDIR%%/deluge/delugegtk.py
-%%PYTHON_SITELIBDIR%%/deluge/delugegtk.pyc
-%%PYTHON_SITELIBDIR%%/deluge/delugegtk.pyo
-%%PYTHON_SITELIBDIR%%/deluge/delugeplugins.py
-%%PYTHON_SITELIBDIR%%/deluge/delugeplugins.pyc
-%%PYTHON_SITELIBDIR%%/deluge/delugeplugins.pyo
%%PYTHON_SITELIBDIR%%/deluge/dgtk.py
%%PYTHON_SITELIBDIR%%/deluge/dgtk.pyc
%%PYTHON_SITELIBDIR%%/deluge/dgtk.pyo
+%%PYTHON_SITELIBDIR%%/deluge/dialogs.py
+%%PYTHON_SITELIBDIR%%/deluge/dialogs.pyc
+%%PYTHON_SITELIBDIR%%/deluge/dialogs.pyo
+%%PYTHON_SITELIBDIR%%/deluge/interface.py
+%%PYTHON_SITELIBDIR%%/deluge/interface.pyc
+%%PYTHON_SITELIBDIR%%/deluge/interface.pyo
%%PYTHON_SITELIBDIR%%/deluge/ipc_manager.py
%%PYTHON_SITELIBDIR%%/deluge/ipc_manager.pyc
%%PYTHON_SITELIBDIR%%/deluge/ipc_manager.pyo
+%%PYTHON_SITELIBDIR%%/deluge/plugins.py
+%%PYTHON_SITELIBDIR%%/deluge/plugins.pyc
+%%PYTHON_SITELIBDIR%%/deluge/plugins.pyo
%%PYTHON_SITELIBDIR%%/deluge/pref.py
%%PYTHON_SITELIBDIR%%/deluge/pref.pyc
%%PYTHON_SITELIBDIR%%/deluge/pref.pyo
@@ -31,7 +34,9 @@ share/applications/deluge.desktop
%%DATADIR%%/glade/aboutdialog.glade
%%DATADIR%%/glade/delugegtk.glade
%%DATADIR%%/glade/dgtkpopups.glade
-%%DATADIR%%/glade/dgtkpref.glade
+%%DATADIR%%/glade/file_tab_menu.glade
+%%DATADIR%%/glade/plugin_dialog.glade
+%%DATADIR%%/glade/preferences_dialog.glade
%%DATADIR%%/glade/torrent_menu.glade
%%DATADIR%%/pixmaps/deluge-about.png
%%DATADIR%%/pixmaps/deluge128.png
@@ -45,6 +50,8 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/HelloWorld/plugin.py
%%DATADIR%%/plugins/NetworkGraph/plugin.py
%%DATADIR%%/plugins/NetworkHealth/plugin.py
+%%DATADIR%%/plugins/TorrentCreator/plugin.py
+%%DATADIR%%/plugins/TorrentCreator/tcreator.glade
%%DATADIR%%/plugins/TorrentSearch/plugin.py
%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -90,6 +97,7 @@ share/pixmaps/deluge.xpm
@dirrmtry share/locale/la
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/plugins/TorrentSearch
+@dirrm %%DATADIR%%/plugins/TorrentCreator
@dirrm %%DATADIR%%/plugins/NetworkHealth
@dirrm %%DATADIR%%/plugins/NetworkGraph
@dirrm %%DATADIR%%/plugins/HelloWorld
e8d9de659e2dc825a6f99adec4a740b055a301a'>Mark MAKE_JOBS_UNSAFE.marcus2009-08-161-0/+1 * Mark MAKE_JOBS_UNSAFE.marcus2009-08-161-0/+1 * Mark MAKE_JOBS_UNSAFE.marcus2009-08-161-0/+1 * Mark MAKE_JOBS_UNSAFE.marcus2009-08-161-0/+1 * Fix the plist when doxygen is installed.marcus2009-08-161-0/+11 * Update to 0.7.32ahze2009-08-162-4/+4 * - Update to version 1.3.5markus2009-08-166-14/+12 * Mark BROKEN on 8.x: does not builderwin2009-08-162-2/+10 * Fix build on 6.x after recent Qt4 updatemakc2009-08-152-2/+11 * - Update to 2.1.2wxs2009-08-152-4/+4 * - Document configuration syntax changes for mail/dovecot.wxs2009-08-151-0/+8 * Update the cURL port to 7.19.6.roam2009-08-159-77/+22 * - Add RC scriptwxs2009-08-153-6/+33 * - Fix build on 8.0 (patch obtained from xca git repo)wxs2009-08-152-13/+138 * - Mark as broken if manage sieve option is selected.wxs2009-08-151-0/+1 * Add minitubemakc2009-08-151-0/+1 * Add new port multimedia/minitube:makc2009-08-154-0/+80 * Mark BROKEN: does not fetcherwin2009-08-151-0/+2 * Mark BROKEN: checksum mismatcherwin2009-08-151-0/+2 * - Update to 1.8dhn2009-08-152-8/+9 * Mark as only for amd64 and i386.linimon2009-08-151-0/+2 * Mark as broken on sparc64: does not compile.linimon2009-08-151-0/+4 * Attempt to fix patching on sparc64.linimon2009-08-151-2/+2 * Mark as broken on sparc64.linimon2009-08-151-1/+7 * Mark as broken on sparc64: fails to compile.linimon2009-08-151-1/+7 * Also broken on sparc64.linimon2009-08-151-1/+1 * Mark as broken on amd64 (leaves files behind on deinstall), and sparc64linimon2009-08-151-2/+10 * - Update to 5.831jadawin2009-08-152-4/+4 * - Update to 3.62jadawin2009-08-152-4/+4 * Update to 0.08skv2009-08-152-4/+4 * - Update to 0.14clsung2009-08-152-4/+4 * Update kdevelop to latest security release.fluffy2009-08-152-7/+19 * - Mark MAKE_JOBS_UNSAFE, fails with forced jobsamdmi32009-08-151-0/+1 * - Update to 1.3.0amdmi32009-08-153-1203/+1324 * Ports modules update at Saturday 15 August 2009 at 00:09edwin2009-08-151-0/+8 * - Fix fetchmiwi2009-08-151-1/+1 * - Bump PORTREVISION due to mail/dovecot update.wxs2009-08-151-0/+1 * - Update to 2.6.3wxs2009-08-1510-50/+55 * - Update to 1.2.3wxs2009-08-154-36/+52 * - Chase graphics/geos shlib bumpmiwi2009-08-156-7/+9 * - Update to 1.2.28wxs2009-08-152-6/+5 * - Update to 3.1.1miwi2009-08-153-5/+5 * Distfiles were rerolled with new examples and documentationerwin2009-08-152-7/+7 * This extension uses libgearman library to provide API formiwi2009-08-154-0/+40 * Apply a patch to make the ipcount script work.dougb2009-08-151-1/+7 * - Update to 2.2.5miwi2009-08-152-5/+5 * This module provides an API for creating a File::ChangeNotify::Watcher subclassmiwi2009-08-155-0/+55 * This module does not provide any methods. Simply loading it changes the defaultmiwi2009-08-155-0/+44 * - Fix build with custom PREFIXmiwi2009-08-151-0/+123 * - Update to 1.44miwi2009-08-152-4/+4 * - Reset PORTREVISION due to PORTVERSION bump in master.wxs2009-08-152-2/+0 * - Update to 1.3.0miwi2009-08-153-1458/+515 * libquantum is a C library for the simulation of quantummiwi2009-08-155-0/+37 * - Update to 3.0.2wxs2009-08-152-7/+7 * - Update to 2.2.4miwi2009-08-152-4/+4 * - Update to 3.0.2 [1]wxs2009-08-1510-47/+14 * - Update to 1.2.7miwi2009-08-152-4/+4 * - A minor upstream patch that fixes a problem with themiwi2009-08-152-2/+7 * - Update to 1.6.2miwi2009-08-153-9/+9 * - Update to 1.14miwi2009-08-154-6/+67 * MailZu is a simple and intuitive web interface to manage Amavisd-newmiwi2009-08-156-0/+318 * - Update to 20090616miwi2009-08-152-4/+4 * - Fix warnings with python 2.6miwi2009-08-152-1/+4 * - Update to 0.133u2miwi2009-08-1510-32/+34 * - Update to 1.14.34miwi2009-08-155-15/+158 * - Update to 3.1.7.1miwi2009-08-156-103/+15 * - Update to 0.14.araujo2009-08-152-4/+4 * - Update to 0.19.araujo2009-08-152-4/+4 * - Fix fetchmiwi2009-08-151-1/+1 * - update to 2.2.0dinoex2009-08-152-4/+4 * - Mark BROKEN checksum mismatchmiwi2009-08-151-0/+2 * - Fix fetchmiwi2009-08-153-3/+5 * - Change to new SFP macromiwi2009-08-151-1/+1 * - Fix SFP macromiwi2009-08-151-2/+1 * - Change to new SFP macromiwi2009-08-151-1/+1 * - Change to new SFP macromiwi2009-08-151-1/+1 * Mark BROKEN: checksum mismatcherwin2009-08-151-0/+2 * Mark BROKEN: does not fetcherwin2009-08-152-0/+4 * - Update to 3.0.51r22226beat2009-08-1545-175/+3045 * - Update to 0.9beat2009-08-142-21/+29 * - Use SFP macro to make fetchabletabthorpe2009-08-141-2/+2 * Mark BROKEN: checksum mismatcherwin2009-08-141-0/+2 * Update to 1.5.24.vsevolod2009-08-142-4/+4 * - Update to 0.2.5amdmi32009-08-142-5/+5 * - Fix build with custom PREFIXmiwi2009-08-142-4/+6 * - Fix build with custom PREFIXmiwi2009-08-141-0/+1 * - Add patch for konsole that implements the missing bits for FreeBSD to makemarkus2009-08-144-2/+296 * As the projectside seems to be dead, move the distfile to MASTER_SITE_LOCALmarkus2009-08-142-4/+2 * - Distfile was rerolledmiwi2009-08-142-4/+4 * - Unbreak build on sparc64miwi2009-08-141-4/+0 * Fix build after recent Qt4 update.makc2009-08-141-1/+7 * - Fix some typosmiwi2009-08-141-3/+3 * Mark BROKEN: does not builderwin2009-08-141-0/+2 * - Mark all math/octave* BROKEN, it fails to build for a long timemiwi2009-08-141-0/+2 * Restore Sourceforge master site using SFP.olgeni2009-08-141-2/+2 * Add checker of hid.lst and a minor fix.maho2009-08-141-1/+8 * Fix build by update to 1.70 for Qt-4.5.0.makc2009-08-143-11/+17 * - Add hamradio to the categorymiwi2009-08-142-2/+2 * Install correct hid.lst.maho2009-08-142-4/+4 * Fix build after Qt4 ports update.makc2009-08-141-0/+3 * - make patches fetchabledinoex2009-08-141-1/+3 * Igbinary is a drop in replacement for the standard PHP serializer.miwi2009-08-144-0/+32 * - Add backup mirrorsmiwi2009-08-1421-22/+42 * Update to 1.30.30.tobez2009-08-142-5/+5 * Update to 1.39.tobez2009-08-142-4/+4 * Add p5-WebService-Google-Sets 0.03, a Perl module that provides accesstobez2009-08-145-0/+41 * - Update to 0.6.3miwi2009-08-142-4/+4 * - Update MASTER_SITESmiwi2009-08-142-4/+2 * make fetchable.maho2009-08-141-1/+2 * Update to the 20090813 snapshot of GCC 4.5.0.gerald2009-08-1410-95/+95 * - add py-miniupnpc to python category.dinoex2009-08-142-1/+2 * - revert patchdinoex2009-08-142-5/+6 * Update to 0.73.0:edwin2009-08-142-4/+4 * - Update to 0.94rafan2009-08-142-4/+4 * Advanced fork of nss_ldap module with standalone daemon.timur2009-08-1430-0/+1284 * - Drop scintilla support, as scintilla no longer supports gtk12amdmi32009-08-142-18/+2 * - Deprecate x11-toolkits/gtkscintilla and x11-toolkits/py-gtkscintillaamdmi32009-08-142-0/+6 * - Update to 2.00amdmi32009-08-142-18/+8 * - Update to 2.00amdmi32009-08-144-29/+19 * Ports modules update at Friday 14 August 2009 at 00:09edwin2009-08-14