aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/deluge
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-20 06:12:04 +0800
committerpawel <pawel@FreeBSD.org>2011-10-20 06:12:04 +0800
commit976494ee39c5cb098d7c990d78db8723eb41fe6b (patch)
treecb54be2ab89e414215d2abe7a7540bc3fa2b6906 /net-p2p/deluge
parented1417b58ae6d5cf4df8c10e305f7bf9acca71ec (diff)
downloadfreebsd-ports-gnome-976494ee39c5cb098d7c990d78db8723eb41fe6b.tar.gz
freebsd-ports-gnome-976494ee39c5cb098d7c990d78db8723eb41fe6b.tar.zst
freebsd-ports-gnome-976494ee39c5cb098d7c990d78db8723eb41fe6b.zip
Fix build when WITHOUT_PYGTK=true
PR: ports/160898 Reported by: Doug Penner <darwinsurvivor@gmail.com> Fix by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> (maintainer)
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/Makefile13
-rw-r--r--net-p2p/deluge/pkg-plist3
2 files changed, 9 insertions, 7 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 73d6fa9a81f0..a51ae86b9739 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -86,8 +86,11 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:${PORTSDIR}/devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:${PORTSDIR}/devel/py-notify \
xdg-utils>=1.0.2:${PORTSDIR}/devel/xdg-utils
+PLIST_SUB+= PYGTK=""
USE_GNOME+= desktopfileutils librsvg2 pygtk2
INSTALLS_ICONS= yes
+.else
+PLIST_SUB+= PYGTK="@comment "
.endif
post-patch:
@@ -114,11 +117,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/hicolor/${size}x${size}/apps/deluge.png \
${PREFIX}/share/icons/hicolor/${size}x${size}/apps
.endfor
- if [ ! -d ${PREFIX}/share/applications ]; then \
- ${MKDIR} ${PREFIX}/share/applications ; \
- fi
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
- ${PREFIX}/share/applications
if [ ! -d ${PREFIX}/share/pixmaps ]; then \
${MKDIR} ${PREFIX}/share/pixmaps ; \
fi
@@ -127,6 +125,11 @@ post-install:
${PREFIX}/share/pixmaps
.endfor
.if !defined(WITHOUT_PYGTK)
+ if [ ! -d ${PREFIX}/share/applications ]; then \
+ ${MKDIR} ${PREFIX}/share/applications ; \
+ fi
+ ${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
+ ${PREFIX}/share/applications
@-update-desktop-database
.endif
.if !defined(NOPORTDOCS)
diff --git a/net-p2p/deluge/pkg-plist b/net-p2p/deluge/pkg-plist
index 45728884a51b..e34590532c61 100644
--- a/net-p2p/deluge/pkg-plist
+++ b/net-p2p/deluge/pkg-plist
@@ -1394,7 +1394,7 @@ bin/deluged
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/deluge/ui/web/web.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/deluge/ui/web/web.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/deluge/ui/web/web.pyo
-share/applications/deluge.desktop
+%%PYGTK%%share/applications/deluge.desktop
share/icons/hicolor/128x128/apps/deluge.png
share/icons/hicolor/16x16/apps/deluge.png
share/icons/hicolor/192x192/apps/deluge.png
@@ -1410,7 +1410,6 @@ share/icons/hicolor/96x96/apps/deluge.png
share/icons/hicolor/scalable/apps/deluge.svg
share/pixmaps/deluge.png
share/pixmaps/deluge.xpm
-@dirrmtry share/pixmaps
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor/96x96/apps