aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/ed2k/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-11-20 20:20:55 +0800
committerdinoex <dinoex@FreeBSD.org>2005-11-20 20:20:55 +0800
commit52603dfc96131fe8ff197053939452df4f1f29a8 (patch)
tree531cee76921ac2057a6d1087bce80b30ea63c374 /net-p2p/ed2k/Makefile
parentbf17c5c1024324219897cd8bc961c124712fb642 (diff)
downloadfreebsd-ports-gnome-52603dfc96131fe8ff197053939452df4f1f29a8.tar.gz
freebsd-ports-gnome-52603dfc96131fe8ff197053939452df4f1f29a8.tar.zst
freebsd-ports-gnome-52603dfc96131fe8ff197053939452df4f1f29a8.zip
This tool takes files and calculates the final 'eEmule' hashes for
then. It also spits out the complete ed2k:// link in the end. Note: This hashes differ from 'eDonkey/mldonkey' hashes when the size of a files is a mutiple of 9728000 Bytes. WWW: http://www.sdalu.com/software/tools.shtml
Diffstat (limited to 'net-p2p/ed2k/Makefile')
-rw-r--r--net-p2p/ed2k/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-p2p/ed2k/Makefile b/net-p2p/ed2k/Makefile
new file mode 100644
index 000000000000..35a5cc6ca35d
--- /dev/null
+++ b/net-p2p/ed2k/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ed2k hash tool
+# Date created: Mi 9 Nov 2005 06:52:38 CET
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ed2k
+PORTVERSION= 1.4
+CATEGORIES= misc
+MASTER_SITES= http://www.sdalu.com/download/software/tools/
+PKGNAMESUFFIX= -hash${PKGNAMESUFFIX2}
+DISTNAME= ed2k.c
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Calculates 'eMule' hashes or producing ed2k:// file links
+
+WRKSRC= ${WRKDIR}
+MAKEFILE= /dev/null
+ALL_TARGET= ed2k
+PLIST_FILES= bin/ed2k
+
+.if defined(WITHOUT_OPENSSL)
+CPPFLAGS+= -DWITH_RSA
+MAKE_ENV+= LDLIBS="${CPPFLAGS}"
+.else
+USE_OPENSSL= yes
+OPENSSLSUFFIX= -openssl
+LDLIBS+= -lmd
+MAKE_ENV+= LDLIBS="${LDLIBS}"
+.endif
+
+post-extract:
+ ${CP} -p ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}/
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ed2k ${PREFIX}/bin/
+
+.include <bsd.port.mk>