aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/edonkey-tool-hash/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-02-21 06:36:43 +0800
committerlioux <lioux@FreeBSD.org>2002-02-21 06:36:43 +0800
commit3caa2756ff67c64f8b6dfeceb3d1012cd98b24d3 (patch)
tree9f19247d548eb2b00ff5c6bc94ea8dbdce03d987 /net-p2p/edonkey-tool-hash/Makefile
parent2328e52332966450edfa41b645d3154994c6d1ca (diff)
downloadfreebsd-ports-gnome-3caa2756ff67c64f8b6dfeceb3d1012cd98b24d3.tar.gz
freebsd-ports-gnome-3caa2756ff67c64f8b6dfeceb3d1012cd98b24d3.tar.zst
freebsd-ports-gnome-3caa2756ff67c64f8b6dfeceb3d1012cd98b24d3.zip
- edonkey-tool-hash version 0.0.1: Both calculates 'eDonkey hashes'
and produces ed2k:// links for files
Diffstat (limited to 'net-p2p/edonkey-tool-hash/Makefile')
-rw-r--r--net-p2p/edonkey-tool-hash/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/edonkey-tool-hash/Makefile b/net-p2p/edonkey-tool-hash/Makefile
new file mode 100644
index 000000000000..4ecca6ab2dc0
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: edonkey hash tool
+# Date created: Wed Feb 20 18:03:49 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= edonkey
+PORTVERSION= 0.0.1
+CATEGORIES= misc
+MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
+PKGNAMESUFFIX= -tool-hash
+DISTNAME= ed2k_hash
+
+MAINTAINER= lioux@FreeBSD.org
+
+# I could have written a Makefile but I would rather
+# not waste inodes
+do-build:
+ @cd ${WRKSRC} && ${CC} -D__linux ${CFLAGS} ${LDFLAGS} -lmd \
+ ed2k_hash.c -o ${PORTNAME}${PKGNAMESUFFIX}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX} \
+ ${PREFIX}/bin
+
+.include <bsd.port.mk>