aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gkrellm-gift/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-05 07:09:08 +0800
committerpav <pav@FreeBSD.org>2004-05-05 07:09:08 +0800
commit36e00580a3452a70b817af0d9b4f1bed45de4791 (patch)
tree0e00bdc50798cff7ab260000f55fafc8cf134098 /net-p2p/gkrellm-gift/Makefile
parent0143b4a45f93413e901afa727bbd326613e50bf8 (diff)
downloadfreebsd-ports-gnome-36e00580a3452a70b817af0d9b4f1bed45de4791.tar.gz
freebsd-ports-gnome-36e00580a3452a70b817af0d9b4f1bed45de4791.tar.zst
freebsd-ports-gnome-36e00580a3452a70b817af0d9b4f1bed45de4791.zip
Add gkrellm-gift, a GKrellM plugin that monitors your active giFT transfers
and their progress. Each transfer is displayed in a panel showing the filename and the percentage of transmitted bytes. PR: ports/66204 Submitted by: Tobias Roth <ports@fsck.ch>
Diffstat (limited to 'net-p2p/gkrellm-gift/Makefile')
-rw-r--r--net-p2p/gkrellm-gift/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/gkrellm-gift/Makefile b/net-p2p/gkrellm-gift/Makefile
new file mode 100644
index 000000000000..6c6e523db539
--- /dev/null
+++ b/net-p2p/gkrellm-gift/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gkrellm-gift
+# Date created: Mon May 3 08:48:47 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gift
+PORTVERSION= 0.2.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/gkrellm-gift/ \
+ http://depot.fsck.ch/mirror/distfiles/
+PKGNAMEPREFIX= gkrellm-
+DISTNAME= ${PKGNAMEPREFIX}giFT-${PORTVERSION}
+
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin that monitors active giFT transfers
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/libexec/gkrellm2/plugins/${PORTNAME}.so
+
+.include <bsd.port.mk>