aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gnunet/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-28 02:57:02 +0800
committerkrion <krion@FreeBSD.org>2003-08-28 02:57:02 +0800
commit12d102c25a74276f09adacc2af82d1addc21b200 (patch)
tree23fa74b8691d2bdd810d73cd485a1194fe9d06bb /net-p2p/gnunet/Makefile
parent307db86b00e7dda0919fe8d1b905a6e301d32de6 (diff)
downloadfreebsd-ports-gnome-12d102c25a74276f09adacc2af82d1addc21b200.tar.gz
freebsd-ports-gnome-12d102c25a74276f09adacc2af82d1addc21b200.tar.zst
freebsd-ports-gnome-12d102c25a74276f09adacc2af82d1addc21b200.zip
- Fix build with MySQL
Diffstat (limited to 'net-p2p/gnunet/Makefile')
-rw-r--r--net-p2p/gnunet/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 5fcf41eff178..0261543359c3 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnunet
PORTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -17,6 +18,8 @@ DISTNAME= GNUnet-${PORTVERSION}
MAINTAINER= krion@FreeBSD.org
COMMENT= An anonymous, distributed, reputation-based network
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
@@ -24,6 +27,7 @@ USE_REINPLACE= yes
USE_BZIP2= yes
USE_OPENSSL= yes
USE_GNOME= gtk12
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -40,6 +44,7 @@ PLIST_SUB+= WITH_GDBM="@comment "
.if defined(WITH_MYSQL)
USE_MYSQL= yes
WANT_MYSQL_VER= 323
+CONFIGURE_ARGS+= --with-mysql
.else
CONFIGURE_ARGS+= --without-mysql
.endif