aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gnunet/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2003-10-14 04:26:33 +0800
committerade <ade@FreeBSD.org>2003-10-14 04:26:33 +0800
commit82bd83968e60d1f73bc94bc574f22bd3ed02ce0c (patch)
treec5088ac4fb21cb784c3c92a0a25003327086f167 /net-p2p/gnunet/Makefile
parentf6bb12baa63886383faba74b2f44d5923cb3a146 (diff)
downloadfreebsd-ports-gnome-82bd83968e60d1f73bc94bc574f22bd3ed02ce0c.tar.gz
freebsd-ports-gnome-82bd83968e60d1f73bc94bc574f22bd3ed02ce0c.tar.zst
freebsd-ports-gnome-82bd83968e60d1f73bc94bc574f22bd3ed02ce0c.zip
Depend on devel/libltdl, rather than installing embedded copy.
Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
Diffstat (limited to 'net-p2p/gnunet/Makefile')
-rw-r--r--net-p2p/gnunet/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index bfc80fadda5a..f4df235c952f 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnunet
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -18,7 +18,8 @@ DISTNAME= GNUnet-${PORTVERSION}
MAINTAINER= krion@FreeBSD.org
COMMENT= An anonymous, distributed, reputation-based network
-LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ ltdl.4:${PORTSDIR}/devel/libltdl
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -31,6 +32,7 @@ USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ARGS= --disable-ltdl-install
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_GDBM)