aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gtk-gnutella/Makefile
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-09-06 22:09:58 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-09-06 22:09:58 +0800
commit5f1ba6f74b3109bb6f719f0b8d09349fe1a2c9c8 (patch)
treea8c401f0deda5a3e77f253b818bf06325e930a49 /net-p2p/gtk-gnutella/Makefile
parent7c1426a1b48517bdb558255d58fe4c26021e06dd (diff)
downloadfreebsd-ports-gnome-5f1ba6f74b3109bb6f719f0b8d09349fe1a2c9c8.tar.gz
freebsd-ports-gnome-5f1ba6f74b3109bb6f719f0b8d09349fe1a2c9c8.tar.zst
freebsd-ports-gnome-5f1ba6f74b3109bb6f719f0b8d09349fe1a2c9c8.zip
net-p2p/gtk-gnutella: Update to 1.1.10
- Add undeclared dependencies detected by qa-stage script - Move helper text from Makefile to pkg-help Approved by: adamw, mat (mentors) Differential Revision: https://reviews.freebsd.org/D7788
Diffstat (limited to 'net-p2p/gtk-gnutella/Makefile')
-rw-r--r--net-p2p/gtk-gnutella/Makefile40
1 files changed, 4 insertions, 36 deletions
diff --git a/net-p2p/gtk-gnutella/Makefile b/net-p2p/gtk-gnutella/Makefile
index 4461ed2d5c48..039e7e503708 100644
--- a/net-p2p/gtk-gnutella/Makefile
+++ b/net-p2p/gtk-gnutella/Makefile
@@ -1,42 +1,8 @@
# Created by: rbt@zort.on.ca
# $FreeBSD$
-#
-# A quick note on configurable make symbols:
-#
-# INTERACTIVE_CONFIGURE: Launches Configure in its default mode, which is
-# *very* interactive. Disabled here by default to conform to FreeBSD
-# guidelines, this mode is useful if you have problems with the
-# default Configure.
-#
-# GUI: Disable this to build a headless version of Gtk-Gnutella. Therefore,
-# monitoring of operations for Gtk-Gnutella will have to be
-# done without relying on any GUI, and the configuration is done via
-# files only.
-#
-# TLS: Enable support for scrambling GNet connections. Currently supported
-# only by Gtk-Gnutella.
-#
-# NLS: Enable National Language Support for translation of User Interface.
-#
-# IPV6: Enable to support IPv6 connections. The real configuration takes
-# place at run-time so keeping it enabled will not force IPv6 usage.
-#
-# DBUS: Enable D-Bus IPC support. Gtk-Gnutella will send out messages onto
-# the D-Bus message bus. That way external applications can easily
-# act on certain events that happen, such as a completed download.
-#
-# DEBUG: Compile with debugging symbols. Useful if you intend to make a
-# bug report.
-#
-# PORTABILITY: Configure code to use the PATH variable at run-time at a
-# cost in performance. Useful if you intend to move the executable
-# to multiple machines.
-#
-
PORTNAME= gtk-gnutella
-PORTVERSION= 1.1.9
-PORTREVISION= 1
+PORTVERSION= 1.1.10
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF
@@ -73,9 +39,11 @@ OPTIONS_SUB= yes
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_CONFIGURE_OFF= -Ud_dbus
DEBUG_CONFIGURE_ON= -Ud_official
-GUI_USE= gnome=gtk20
+GUI_USE= gnome=gtk20,cairo
GUI_VARS= INSTALLS_ICONS=yes
GUI_CONFIGURE_OFF= -Dd_headless
+GUI_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
IPV6_CONFIGURE_OFF= -Ud_ipv6
NLS_USES= gettext
NLS_CONFIGURE_OFF= -Ud_nls