aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gtkhx/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-02-11 16:37:57 +0800
committerkevlo <kevlo@FreeBSD.org>2002-02-11 16:37:57 +0800
commit93114272db03b759843ee1e58d9542ef44a33d48 (patch)
tree5859b023b9a8594757a79ec5c20db89be783f6d8 /net-p2p/gtkhx/Makefile
parent5c5eb57640c81f0dc7775a64ac3c6e41be5cba0f (diff)
downloadfreebsd-ports-gnome-93114272db03b759843ee1e58d9542ef44a33d48.tar.gz
freebsd-ports-gnome-93114272db03b759843ee1e58d9542ef44a33d48.tar.zst
freebsd-ports-gnome-93114272db03b759843ee1e58d9542ef44a33d48.zip
Initial import of gtkhx 0.9.1
Gtkhx is a GTK+ version of Hx, a UNIX Hotline Client. PR: 34785 Submitted by: Josh Elsasser <joshe@jade.elsasser.org>
Diffstat (limited to 'net-p2p/gtkhx/Makefile')
-rw-r--r--net-p2p/gtkhx/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/gtkhx/Makefile b/net-p2p/gtkhx/Makefile
new file mode 100644
index 000000000000..a14579aa712e
--- /dev/null
+++ b/net-p2p/gtkhx/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gtkhx
+# Date created: 9 February 2002
+# Whom: Josh Elsasser <jre@vineyard.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkhx
+PORTVERSION= 0.9.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkhx
+
+MAINTAINER= jre@vineyard.net
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf:install \
+ intl.1:${PORTSDIR}/devel/gettext:install \
+ iconv.2:${PORTSDIR}/converters/iconv:install
+
+USE_XLIB= yes
+USE_GLIB= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-libiconv-prefix=${PREFIX}
+
+MAN1= gtkhx.1
+
+.include <bsd.port.mk>