aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/libtorrent-devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-01-15 21:18:57 +0800
committeraz <az@FreeBSD.org>2013-01-15 21:18:57 +0800
commit0cb0ccc337ac7adbda80fe331b7f88a7f2f5cadb (patch)
treed6fd63cc871a5e3e6f900d273cbe0be1e820a63d /net-p2p/libtorrent-devel
parent705ddc9158f34f47c83e6a31ed6fb850cb76229f (diff)
downloadfreebsd-ports-gnome-0cb0ccc337ac7adbda80fe331b7f88a7f2f5cadb.tar.gz
freebsd-ports-gnome-0cb0ccc337ac7adbda80fe331b7f88a7f2f5cadb.tar.zst
freebsd-ports-gnome-0cb0ccc337ac7adbda80fe331b7f88a7f2f5cadb.zip
separate logic for these two group of ports.
Diffstat (limited to 'net-p2p/libtorrent-devel')
-rw-r--r--net-p2p/libtorrent-devel/Makefile45
-rw-r--r--net-p2p/libtorrent-devel/pkg-descr5
2 files changed, 43 insertions, 7 deletions
diff --git a/net-p2p/libtorrent-devel/Makefile b/net-p2p/libtorrent-devel/Makefile
index 10385a9f2f68..fc3617fef6e8 100644
--- a/net-p2p/libtorrent-devel/Makefile
+++ b/net-p2p/libtorrent-devel/Makefile
@@ -7,20 +7,51 @@
PORTNAME= libtorrent-devel
PORTVERSION= 0.13.1
+PORTREVISION= 1
+CATEGORIES= net-p2p
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= az@FreeBSD.org
COMMENT= BitTorrent Library written in C++ (development version)
-MASTERDIR= ${.CURDIR}/../libtorrent
-PATCHDIR= ${.CURDIR}/files/
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${MASTERDIR}/pkg-descr
-
+LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
CONFLICTS= libtorrent-[0-9]* \
rblibtorrent-[0-9]* \
rblibtorrent-devel-[0-9]*
-.include "${MASTERDIR}/Makefile"
+USE_AUTOTOOLS= libtool
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= KQUEUE IPV6
+OPTIONS_DEFAULT= KQUEUE
+KQUEUE_DESC= Use kqueue(2) support
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENSSL_BASE)
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
+.endif
+
+CONFIGURE_ARGS+= --disable-debug --with-openssl=${OPENSSLBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+
+.if ${PORT_OPTIONS:MKQUEUE}
+CONFIGURE_ARGS+= --with-kqueue
+.endif
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/libtorrent-devel/pkg-descr b/net-p2p/libtorrent-devel/pkg-descr
new file mode 100644
index 000000000000..b442773d1c2f
--- /dev/null
+++ b/net-p2p/libtorrent-devel/pkg-descr
@@ -0,0 +1,5 @@
+LibTorrent is a BitTorrent library written in C++ for *nix. It is
+designed to avoid redundant copying and storing of data that other
+clients and libraries suffer from. Licensed under the GPL.
+
+WWW: http://libtorrent.rakshasa.no/