aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/linux-edonkey-server/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-05-29 00:33:27 +0800
committerlioux <lioux@FreeBSD.org>2002-05-29 00:33:27 +0800
commitce8ec5674a406b715b4bf0cef4fb051cd4b41b4c (patch)
treeb08004a9c91e21a6ba843030256e2faea74c9c2a /net-p2p/linux-edonkey-server/Makefile
parent085aae7bb8148d12d497978e073367205689e2aa (diff)
downloadfreebsd-ports-gnome-ce8ec5674a406b715b4bf0cef4fb051cd4b41b4c.tar.gz
freebsd-ports-gnome-ce8ec5674a406b715b4bf0cef4fb051cd4b41b4c.tar.zst
freebsd-ports-gnome-ce8ec5674a406b715b4bf0cef4fb051cd4b41b4c.zip
After update of linux_base to 7.1 in rev 1.60, correct detection
of strip tool since it is not part of 7.1
Diffstat (limited to 'net-p2p/linux-edonkey-server/Makefile')
-rw-r--r--net-p2p/linux-edonkey-server/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-p2p/linux-edonkey-server/Makefile b/net-p2p/linux-edonkey-server/Makefile
index bdea5750e4a8..48bbcf85e5b3 100644
--- a/net-p2p/linux-edonkey-server/Makefile
+++ b/net-p2p/linux-edonkey-server/Makefile
@@ -44,12 +44,6 @@ post-patch:
-e "s|%%LOCALBASE%%|${LOCALBASE}|" ${FILESDIR}/${RC_SAMPLE} \
> ${WRKDIR}/${RC_SAMPLE}
-pre-install:
-.if exists(${STRIP_CMD})
-# @${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
-.endif
- @${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
-
do-install:
# pre-install work: create user ids, ...
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
@@ -58,4 +52,12 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${RC_SAMPLE} ${PREFIX}/etc/rc.d
@${INSTALL_DATA} ${FILESDIR}/donkey.ini ${PREFIX}/etc/edonkey2000
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-install:
+.if exists(${STRIP_CMD})
+ @${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
+.endif
+ @${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
+
+.include <bsd.port.post.mk>