aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/namecoin-daemon
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-09-04 02:39:51 +0800
committerrene <rene@FreeBSD.org>2018-09-04 02:39:51 +0800
commit89d89d3bdc887c0e03c966af6b58c9fcd274ea33 (patch)
treef1c4decb69ab780f51f4ba0d0f1b1846d4185051 /net-p2p/namecoin-daemon
parent48b12d9f2758e4d03a0870bda2858aeb9feb27ca (diff)
downloadfreebsd-ports-gnome-89d89d3bdc887c0e03c966af6b58c9fcd274ea33.tar.gz
freebsd-ports-gnome-89d89d3bdc887c0e03c966af6b58c9fcd274ea33.tar.zst
freebsd-ports-gnome-89d89d3bdc887c0e03c966af6b58c9fcd274ea33.zip
net-p2p/namecoin[-daemon]: unbreak, unexpire, update to 0.13.2
This is part one of the PR. PR: 218961 Submitted by: maintainer
Diffstat (limited to 'net-p2p/namecoin-daemon')
-rw-r--r--net-p2p/namecoin-daemon/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/net-p2p/namecoin-daemon/Makefile b/net-p2p/namecoin-daemon/Makefile
index 3ece9bcc3f36..f79bb5e968d5 100644
--- a/net-p2p/namecoin-daemon/Makefile
+++ b/net-p2p/namecoin-daemon/Makefile
@@ -1,13 +1,29 @@
# $FreeBSD$
-PKGNAMESUFFIX= -daemon
-
MASTERDIR= ${.CURDIR}/../namecoin
-DESCR= ${MASTERDIR}/pkg-descr
+PKGNAMESUFFIX= -daemon
+COMMENT= Decentralized, open DNS and more (Daemon)
SLAVE_PORT= yes
-OPTIONS_EXCLUDE= X11 DBUS QRCODES
+ONLY_FOR_ARCHS= amd64 i386 ia64
+ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
+
+CONFLICTS_INSTALL= namecoin-stable-[0-9]* namecoin-stable-daemon-[0-9]* namecoin-stable-utils-[0-9]* \
+ namecoin-beta-[0-9]* namecoin-beta-daemon-[0-9]* namecoin-beta-utils-[0-9]*
+
+OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
+OPTIONS_DEFAULT= HARDENING UPNP WALLET
+
+CONFIGURE_ARGS= --with-daemon \
+ --without-gui \
+ --without-libs \
+ --without-qrencode \
+ --without-utils
+
+PLIST_FILES= bin/namecoind
+
+USE_RC_SUBR= namecoind
.include "${MASTERDIR}/Makefile"