aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/p5-Net-BitTorrent-PeerPacket
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-23 08:55:33 +0800
committerclsung <clsung@FreeBSD.org>2006-08-23 08:55:33 +0800
commit9c39fdee2954a45363bc193954da7e80cc0464d1 (patch)
tree2f949000478016da568e76c073d6bc93ff7e63ab /net-p2p/p5-Net-BitTorrent-PeerPacket
parenta97fceac7f4dd99cf45b0620fdfd41415e0fd3a1 (diff)
downloadfreebsd-ports-gnome-9c39fdee2954a45363bc193954da7e80cc0464d1.tar.gz
freebsd-ports-gnome-9c39fdee2954a45363bc193954da7e80cc0464d1.tar.zst
freebsd-ports-gnome-9c39fdee2954a45363bc193954da7e80cc0464d1.zip
Add p5-Net-BitTorrent-PeerPacket 1.0, parse/Build Peer Packets from
BitTorrent. PR: ports/102397 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net-p2p/p5-Net-BitTorrent-PeerPacket')
-rw-r--r--net-p2p/p5-Net-BitTorrent-PeerPacket/Makefile28
-rw-r--r--net-p2p/p5-Net-BitTorrent-PeerPacket/distinfo3
-rw-r--r--net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-descr6
-rw-r--r--net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/net-p2p/p5-Net-BitTorrent-PeerPacket/Makefile b/net-p2p/p5-Net-BitTorrent-PeerPacket/Makefile
new file mode 100644
index 000000000000..8741dd0bec4c
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-PeerPacket/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-BitTorrent-PeerPacket
+# Date created: 2006-08-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-BitTorrent-PeerPacket
+PORTVERSION= 1.0
+CATEGORIES= net-p2p perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Parse/Build Peer Packets from BitTorrent
+
+PERL_MODBUILD= yes
+
+MAN3= Net::BitTorrent::PeerPacket.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/p5-Net-BitTorrent-PeerPacket/distinfo b/net-p2p/p5-Net-BitTorrent-PeerPacket/distinfo
new file mode 100644
index 000000000000..f8d5a8ef02e5
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-PeerPacket/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-BitTorrent-PeerPacket-1.0.tar.gz) = f43c42227e8ffc7edfae71d7e8c28322
+SHA256 (Net-BitTorrent-PeerPacket-1.0.tar.gz) = e0af77a0891389c528dec5abbc227e0aca3c9ea261d41a98a5a0879125651d6e
+SIZE (Net-BitTorrent-PeerPacket-1.0.tar.gz) = 5713
diff --git a/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-descr b/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-descr
new file mode 100644
index 000000000000..fb7525864197
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-descr
@@ -0,0 +1,6 @@
+Net::BitTorrent::PeerPacket handles parsing and building binary data
+shared between BitTorrent peers. The module optinally exports a single
+subroutine for building packets and another for parsing packets, as
+well as, a constant for each packet type defined by BitTorrent.
+
+WWW: http://search.cpan.org/dist/Net-BitTorrent-PeerPacket/
diff --git a/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-plist b/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-plist
new file mode 100644
index 000000000000..425171e2370c
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent-PeerPacket/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/BitTorrent/PeerPacket.pm
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/Net